]> code.ossystems Code Review - openembedded-core.git/commitdiff
btrfs-tools: don't run autogen.sh
authorRoss Burton <ross.burton@intel.com>
Fri, 17 Feb 2017 16:58:32 +0000 (16:58 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Feb 2017 20:29:17 +0000 (12:29 -0800)
Instead of running autogen.sh (which runs autoconf et al) before running
autoreconf (which runs autoreconf et al...) just do the one task that we need
from autogen.sh: copying install-sh from automake's libdir.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb

index 7047c4340243627fcb3b830517fe611282fb8a4a..04e1e6195c0a8e0d004c3d7278f0fc0b21a5650a 100644 (file)
@@ -14,17 +14,17 @@ DEPENDS = "util-linux attr e2fsprogs lzo acl udev"
 RDEPENDS_${PN} = "libgcc"
 
 SRCREV = "144a19145e248513c7a676defad59836830535c6"
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
-"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
 
 inherit autotools-brokensep pkgconfig manpages
 
 PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
 EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
 
-
 do_configure_prepend() {
-      sh autogen.sh
+       # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
+       mkdir -p ${S}/config
+       cp -f $(automake --print-libdir)/install-sh ${S}/config/
 }
 
 S = "${WORKDIR}/git"