]> code.ossystems Code Review - openembedded-core.git/commitdiff
llvm: support older toolchains
authorRoss Burton <ross.burton@intel.com>
Thu, 28 Mar 2019 12:35:29 +0000 (12:35 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Mar 2019 08:28:55 +0000 (08:28 +0000)
LLVM is now warning if your host compiler is gcc <5.1, and some of our supported
operating systems still only have 4.8.5.  Set
LLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN so those builds continue to work, hopefully
we retire the old operating systems before LLVM requires 5.1+.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/llvm/llvm_git.bb

index 01a7da8ebdca0d0c235fffa19b3a751910efcce7..7832441482efc4182d1ac221dab9325c11849b82 100644 (file)
@@ -70,6 +70,7 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
                   -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
                   -DLLVM_OPTIMIZED_TABLEGEN=ON \
                   -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
+                  -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
                   -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
                   -G Ninja"