]> code.ossystems Code Review - openembedded-core.git/commitdiff
upgrade dbus to 1.2.4
authorVivian Zhang <vivian.zhang@intel.com>
Wed, 12 Nov 2008 05:44:47 +0000 (13:44 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 1 Dec 2008 17:59:32 +0000 (17:59 +0000)
meta-moblin/conf/distro/include/moblin-fixed-revisions.inc
meta/packages/dbus/dbus-1.2.4/99_dbus [new file with mode: 0644]
meta/packages/dbus/dbus-1.2.4/cross.patch [new file with mode: 0644]
meta/packages/dbus/dbus-1.2.4/dbus-1.init [new file with mode: 0644]
meta/packages/dbus/dbus-1.2.4/fix-install-daemon.patch [new file with mode: 0644]
meta/packages/dbus/dbus-1.2.4/tmpdir.patch [new file with mode: 0644]
meta/packages/dbus/dbus-native_1.2.4.bb [new file with mode: 0644]
meta/packages/dbus/dbus_1.2.4.bb [new file with mode: 0644]

index 9c92bc629e32abca3b1da689641915854718a6b4..da0bd4659c058303ffd247e7ba5a76cf34742bd7 100644 (file)
@@ -2,6 +2,8 @@
 # Known good source dates/revisions/tags to use, for where Moblin deviates 
 # from Poky:
 #
+PREFERRED_VERSION_dbus ?= "1.2.4"
+PREFERRED_VERSION_dbus-native ?= "1.2.4"
 
 PREFERRED_VERSION_atk ?= "1.24.0"
 PREFERRED_VERSION_pixman ?= "0.12.0"
diff --git a/meta/packages/dbus/dbus-1.2.4/99_dbus b/meta/packages/dbus/dbus-1.2.4/99_dbus
new file mode 100644 (file)
index 0000000..6821ae4
--- /dev/null
@@ -0,0 +1 @@
+d messagebus messagebus 0755 /var/run/dbus none
diff --git a/meta/packages/dbus/dbus-1.2.4/cross.patch b/meta/packages/dbus/dbus-1.2.4/cross.patch
new file mode 100644 (file)
index 0000000..268a3ae
--- /dev/null
@@ -0,0 +1,10 @@
+--- /tmp/configure.in  2006-11-09 21:47:10.000000000 +0100
++++ dbus-0.95/configure.in     2006-11-09 21:48:13.108554000 +0100
+@@ -719,6 +719,7 @@
+     exit (0);
+ ]])],
+               [ac_cv_have_abstract_sockets=yes],
++            [ac_cv_have_abstract_sockets=no],
+               [ac_cv_have_abstract_sockets=no]
+ )])
+ AC_LANG_POP(C)
diff --git a/meta/packages/dbus/dbus-1.2.4/dbus-1.init b/meta/packages/dbus/dbus-1.2.4/dbus-1.init
new file mode 100644 (file)
index 0000000..4abc4cb
--- /dev/null
@@ -0,0 +1,121 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides:          dbus
+# Required-Start:    $remote_fs $syslog
+# Required-Stop:     $remote_fs $syslog
+# Default-Start:     2 3 4 5
+# Default-Stop:      1
+# Short-Description: D-Bus systemwide message bus
+# Description:       D-Bus is a simple interprocess messaging system, used
+#                    for sending messages between applications.
+### END INIT INFO
+#
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus ]; then
+  . /etc/default/dbus
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+  if [ ! -d $PIDDIR ]; then
+    mkdir -p $PIDDIR
+    chown $DAEMONUSER $PIDDIR
+    chgrp $DAEMONUSER $PIDDIR
+  fi
+  if [ -e $PIDFILE ]; then
+    PIDDIR=/proc/$(cat $PIDFILE)
+    if [ -d ${PIDDIR} -a  "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then 
+      echo "$DESC already started; not starting."
+    else
+      echo "Removing stale PID file $PIDFILE."
+      rm -f $PIDFILE
+    fi
+  fi
+
+  if [ ! -d $UUIDDIR ]; then
+    mkdir -p $UUIDDIR
+    chown $DAEMONUSER $UUIDDIR
+    chgrp $DAEMONUSER $UUIDDIR
+  fi
+  dbus-uuidgen --ensure  
+
+  echo -n "Starting $DESC: "
+  start-stop-daemon --start --quiet --pidfile $PIDFILE \
+    --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+  echo "$NAME."
+  if [ -d $EVENTDIR ]; then
+      run-parts --arg=start $EVENTDIR
+  fi
+}
+
+shut_it_down()
+{
+  if [ -d $EVENTDIR ]; then
+      # TODO: --reverse when busybox supports it
+      run-parts --arg=stop $EVENTDIR
+  fi
+  echo -n "Stopping $DESC: "
+  start-stop-daemon --stop  --quiet --pidfile $PIDFILE \
+    --user $DAEMONUSER
+  # We no longer include these arguments so that start-stop-daemon
+  # can do its job even given that we may have been upgraded.
+  # We rely on the pidfile being sanely managed
+  # --exec $DAEMON -- --system $PARAMS
+  echo "$NAME."
+  rm -f $PIDFILE
+}
+
+reload_it()
+{
+  echo -n "Reloading $DESC config: "
+  dbus-send --print-reply --system --type=method_call \
+            --dest=org.freedesktop.DBus \
+            / org.freedesktop.DBus.ReloadConfig > /dev/null
+  # hopefully this is enough time for dbus to reload it's config file.
+  echo "done."
+}
+
+case "$1" in
+  start)
+    start_it_up
+  ;;
+  stop)
+    shut_it_down
+  ;;
+  reload|force-reload)
+    reload_it
+  ;;
+  restart)
+    shut_it_down
+    sleep 1
+    start_it_up
+  ;;
+  *)
+    echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
+    exit 1
+  ;;
+esac
+
+exit 0
diff --git a/meta/packages/dbus/dbus-1.2.4/fix-install-daemon.patch b/meta/packages/dbus/dbus-1.2.4/fix-install-daemon.patch
new file mode 100644 (file)
index 0000000..c317863
--- /dev/null
@@ -0,0 +1,13 @@
+Index: dbus-0.94/bus/Makefile.am
+===================================================================
+--- dbus-0.94.orig/bus/Makefile.am     2006-10-01 17:36:18.000000000 +0200
++++ dbus-0.94/bus/Makefile.am  2006-10-14 21:40:05.000000000 +0200
+@@ -110,7 +110,7 @@
+               $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+               chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+       fi
+-      $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
++      $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
+       $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+       $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
+       $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/meta/packages/dbus/dbus-1.2.4/tmpdir.patch b/meta/packages/dbus/dbus-1.2.4/tmpdir.patch
new file mode 100644 (file)
index 0000000..838b903
--- /dev/null
@@ -0,0 +1,30 @@
+--- dbus-0.22/configure.in.orig        2004-08-13 00:57:16.000000000 +0200
++++ dbus-0.22/configure.in     2004-12-30 21:15:57.000000000 +0100
+@@ -1047,15 +1048,18 @@
+ AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
+ #### Find socket directories
+-if ! test -z "$TMPDIR" ; then
+-   DEFAULT_SOCKET_DIR=$TMPDIR
+-elif ! test -z "$TEMP" ; then
+-   DEFAULT_SOCKET_DIR=$TEMP
+-elif ! test -z "$TMP" ; then
+-   DEFAULT_SOCKET_DIR=$TMP
+-else
+-   DEFAULT_SOCKET_DIR=/tmp
+-fi
++#if ! test -z "$TMPDIR" ; then
++#   DEFAULT_SOCKET_DIR=$TMPDIR
++#elif ! test -z "$TEMP" ; then
++#   DEFAULT_SOCKET_DIR=$TEMP
++#elif ! test -z "$TMP" ; then
++#   DEFAULT_SOCKET_DIR=$TMP
++#else
++#   DEFAULT_SOCKET_DIR=/tmp
++#fi
++
++# checks disabled to avoid expanding this at build time
++DEFAULT_SOCKET_DIR=/tmp
+ if ! test -z "$with_test_socket_dir" ; then
+    TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/meta/packages/dbus/dbus-native_1.2.4.bb b/meta/packages/dbus/dbus-native_1.2.4.bb
new file mode 100644 (file)
index 0000000..3578572
--- /dev/null
@@ -0,0 +1,18 @@
+require dbus.inc
+inherit native
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
+
+do_stage() {
+       oe_runmake install
+       autotools_stage_all
+
+       # for dbus-glib-native introspection generation
+       install -d ${STAGING_DATADIR}/dbus
+       install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}
+
+do_install() {
+       :
+}
diff --git a/meta/packages/dbus/dbus_1.2.4.bb b/meta/packages/dbus/dbus_1.2.4.bb
new file mode 100644 (file)
index 0000000..25ab98b
--- /dev/null
@@ -0,0 +1,4 @@
+include dbus.inc
+
+
+SRC_URI += "file://fix-install-daemon.patch;patch=1 "