]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools: Use STAGING_DATADIR_NATIVE for config.rpath
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 15:58:25 +0000 (15:58 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 19 Oct 2012 12:34:51 +0000 (13:34 +0100)
For builds that don't use gettext, config.rpath may not exist in the target
datadir. This change uses the native directory where it will always
be present due to gettext-minimal-native (which allows us to autoreconf
recipes using gettext even if we don't have gettext built).

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/autotools.bbclass

index 59c5bae8fadb1ca4df3c48cafe5648d8ae3a18c2..b97d74b8d18e813133f6733881b92936424f842d 100644 (file)
@@ -175,9 +175,9 @@ autotools_do_configure() {
                        fi
                else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
                        # We'd call gettextize here if it wasn't so broken...
-                               cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
+                               cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
                                if [ -d ${S}/po/ ]; then
-                                       cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
+                                       cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
                                fi
                                for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do
                                        for j in `find ${S} -name $i | grep -v aclocal-copy`; do