]> code.ossystems Code Review - openembedded-core.git/commitdiff
netbase: Disable networkmanager on eth0 for omap-3430ldp
authorRichard Purdie <richard@openedhand.com>
Wed, 16 Jul 2008 08:42:36 +0000 (08:42 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 16 Jul 2008 08:42:36 +0000 (08:42 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4844 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/netbase/netbase/interfaces
meta/packages/netbase/netbase_4.21.bb

index dc6b823002b8bfa836c42ec59dc41548b4e4d173..b06924fa94916bc434d1103511afb6f84b1a7f21 100644 (file)
@@ -20,10 +20,10 @@ iface eth1 inet dhcp
 # Ethernet/RNDIS gadget (g_ether)
 # ... or on host side, usbnet and random hwaddr
 iface usb0 inet static
-       address 192.168.0.202
+       address 192.168.7.2
        netmask 255.255.255.0
-       network 192.168.0.0
-       gateway 192.168.0.200
+       network 192.168.7.0
+       gateway 192.168.7.1
 
 # Bluetooth networking
 iface bnep0 inet dhcp
index a9df13d17a4d4bec36be47bd07c91f69dba77f45..c629da1d74a071c9e05e4817f670b8af5263136f 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
 infrastructure for basic TCP/IP based networking."
 SECTION = "base"
 LICENSE = "GPL"
-PR = "r17"
+PR = "r18"
 
 inherit update-rc.d
 
@@ -37,6 +37,13 @@ do_install () {
        install -m 0755 update-inetd ${D}${sbindir}/
        install -m 0644 update-inetd.8 ${D}${mandir}/man8/
        install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
+       
+       # Disable network manager on machines that commonly do NFS booting
+       if [ "${MACHINE}" = "omap-3430ldp" ]; then
+               touch ${D}${sysconfdir}/network/nm-disabled-eth0
+       fi
 }
 
 CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
+
+PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"