]> code.ossystems Code Review - openembedded-core.git/commitdiff
dropbear: upgrade to version 5.02
authorQing He <qing.he@intel.com>
Mon, 5 Jul 2010 02:34:19 +0000 (10:34 +0800)
committerJoshua Lock <josh@linux.intel.com>
Wed, 7 Jul 2010 16:12:12 +0000 (17:12 +0100)
from 0.49
clarify license

changes:
  - rebase allow-nopw.patch, some fields in the original file are renamed
  - rebase urandom-xauth-changes-to-options.h.patch, urandom change is
    already in upstream

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/dropbear/dropbear-0.52/configure.patch [moved from meta/packages/dropbear/dropbear-0.49/configure.patch with 100% similarity]
meta/packages/dropbear/dropbear.inc
meta/packages/dropbear/dropbear/allow-nopw.patch
meta/packages/dropbear/dropbear/urandom-xauth-changes-to-options.h.patch
meta/packages/dropbear/dropbear_0.52.bb [moved from meta/packages/dropbear/dropbear_0.49.bb with 73% similarity]

index 7f5dbe356b2f4bdd6cdd861a9f84652c5b6e42db..1d78d5c59b53d826ea6b255b0645942464c19a52 100644 (file)
@@ -1,7 +1,12 @@
 DESCRIPTION = "Dropbear is a lightweight SSH and SCP Implementation"
 HOMEPAGE = "http://matt.ucc.asn.au/dropbear/dropbear.html"
 SECTION = "console/network"
+
+# some files are from other projects and have others license terms:
+#   public domain, OpenSSH 3.5p1, OpenSSH3.6.1p2, PuTTY
 LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3a5b0c2f0d0c49dfde9558ae2036683c"
+
 DEPENDS = "zlib"
 PROVIDES = "ssh sshd"
 RPROVIDES = "ssh sshd"
index 1a709b8da09ea6278b08c9318bcbd4527c905983..2ae361c63eb132c87de7b582ac9e15654cb6fc48 100644 (file)
@@ -1,33 +1,34 @@
-diff -Nurd dropbear-0.45/svr-auth.c dropbear-0.45.patched/svr-auth.c
---- dropbear-0.45/svr-auth.c   2005-03-06 20:27:02.000000000 -0800
-+++ dropbear-0.45.patched/svr-auth.c   2005-03-08 15:22:43.998592744 -0800
-@@ -237,6 +237,7 @@
+diff --git a/svr-auth.c b/svr-auth.c
+index 5da0aa7..4de4964 100644
+--- a/svr-auth.c
++++ b/svr-auth.c
+@@ -249,6 +249,7 @@ static int checkusername(unsigned char *username, unsigned int userlen) {
        }
  
        /* check for an empty password */
 +#ifdef DISALLOW_EMPTY_PW
-       if (ses.authstate.pw->pw_passwd[0] == '\0') {
+       if (ses.authstate.pw_passwd[0] == '\0') {
                TRACE(("leave checkusername: empty pword"))
                dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
-@@ -244,7 +245,7 @@
+@@ -256,6 +257,7 @@ static int checkusername(unsigned char *username, unsigned int userlen) {
                send_msg_userauth_failure(0, 1);
                return DROPBEAR_FAILURE;
        }
--
 +#endif
-       TRACE(("shell is %s", ses.authstate.pw->pw_shell))
  
-       /* check that the shell is set */
-diff -Nurd dropbear-0.45/svr-authpasswd.c dropbear-0.45.patched/svr-authpasswd.c
---- dropbear-0.45/svr-authpasswd.c     2005-03-06 20:27:02.000000000 -0800
-+++ dropbear-0.45.patched/svr-authpasswd.c     2005-03-08 15:22:44.010591023 -0800
-@@ -64,9 +64,13 @@
+       TRACE(("shell is %s", ses.authstate.pw_shell))
+diff --git a/svr-authpasswd.c b/svr-authpasswd.c
+index 53550a2..7b896bd 100644
+--- a/svr-authpasswd.c
++++ b/svr-authpasswd.c
+@@ -64,9 +64,13 @@ void svr_auth_password() {
         * since the shadow password may differ to that tested
         * in auth.c */
        if (passwdcrypt[0] == '\0') {
 +#ifdef DISALLOW_EMPTY_PASSWD
                dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
-                               ses.authstate.printableuser);
+                               ses.authstate.pw_name);
                send_msg_userauth_failure(0, 1);
 +#else
 +              send_msg_userauth_success();
index e2b1dd5da50155d9e331370f041e5bd45a798f99..75ba306565d61c2beba393b9264efc6b28456a38 100644 (file)
@@ -1,15 +1,6 @@
 diff -Nurd dropbear-0.45/options.h dropbear-0.45.patched/options.h
 --- dropbear-0.45/options.h    2005-03-06 20:27:02.000000000 -0800
 +++ dropbear-0.45.patched/options.h    2005-03-08 15:25:09.368742090 -0800
-@@ -143,7 +143,7 @@
-  * however significantly reduce the security of your ssh connections
-  * if the PRNG state becomes guessable - make sure you know what you are
-  * doing if you change this. */
--#define DROPBEAR_RANDOM_DEV "/dev/random"
-+#define DROPBEAR_RANDOM_DEV "/dev/urandom"
- /* prngd must be manually set up to produce output */
- /*#define DROPBEAR_PRNGD_SOCKET "/var/run/dropbear-rng"*/
 @@ -167,7 +167,7 @@
  /* The command to invoke for xauth when using X11 forwarding.
   * "-q" for quiet */
similarity index 73%
rename from meta/packages/dropbear/dropbear_0.49.bb
rename to meta/packages/dropbear/dropbear_0.52.bb
index 929eeb81744c4d182cec90451bdebb72e856f534..51217ea39d6f2e89a0fd4ab0bfa59b86acbc1711 100644 (file)
@@ -1,3 +1,3 @@
 require dropbear.inc
 
-PR="r2"
+PR="r0"