]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance: ensure zip file is linked locally
authorSaul Wold <sgw@linux.intel.com>
Thu, 11 Oct 2012 18:40:26 +0000 (11:40 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 11:03:28 +0000 (12:03 +0100)
This makes the symbolic link portable with the dated zip file, otherwise
the link still points to the original deploy directory.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/images/build-appliance-image.bb

index 49e250d360862e8a26dda69f0c0d0791da3d808f..59ccb98b0281e8d1b6869a15436f4b2f8efa1117 100644 (file)
@@ -80,7 +80,7 @@ create_bundle_files () {
        cp *.vmx* Yocto_Build_Appliance
        ln -sf ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.vmdk Yocto_Build_Appliance/Yocto_Build_Appliance.vmdk
        zip -r ${DEPLOY_DIR_IMAGE}/Yocto_Build_Appliance-${DATETIME}.zip Yocto_Build_Appliance
-       ln -sf ${DEPLOY_DIR_IMAGE}/Yocto_Build_Appliance-${DATETIME}.zip ${DEPLOY_DIR_IMAGE}/Yocto_Build_Appliance.zip 
+       ln -sf Yocto_Build_Appliance-${DATETIME}.zip ${DEPLOY_DIR_IMAGE}/Yocto_Build_Appliance.zip 
 }
 
 python do_bundle_files() {