]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Fix rpm -V usage
authorMark Hatle <mark.hatle@windriver.com>
Mon, 12 May 2014 15:35:34 +0000 (10:35 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 12:42:10 +0000 (13:42 +0100)
[YOCTO #6309]

It appears a logic issue has caused rpm -V to no longer
verify the files on the filesystem match what was installed.

(From OE-Core rev: 117862cd0eebf6887c2ea6cc353432caee2653aa)

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.4.9.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch b/meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch
new file mode 100644 (file)
index 0000000..fddac7a
--- /dev/null
@@ -0,0 +1,22 @@
+lib/verify.c: Fix rpm -V file processing
+
+rpm -V should verify the md5sum and other values on individual files.
+A logic error in the query for GHOST files prevented this from working.
+
+[ Upstream-Status: Submitted ]
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: rpm-5.4.9/lib/verify.c
+===================================================================
+--- rpm-5.4.9.orig/lib/verify.c
++++ rpm-5.4.9/lib/verify.c
+@@ -587,7 +587,7 @@ uint32_t fc = rpmfiFC(fi);
+       /* If not verifying %ghost, skip ghost files. */
+       /* XXX the broken!!! logic disables %ghost queries always. */
+-      if (!(FF_ISSET(qva->qva_fflags, GHOST) && FF_ISSET(fflags, GHOST)))
++      if (!(FF_ISSET(qva->qva_fflags, GHOST)) && FF_ISSET(fflags, GHOST))
+           continue;
+       /* Gather per-file data into a carrier. */
index dbdab1a5e39264409c4d0b510470561d8522f813..43f46ed02432b665e79d7576104c04113e76f447 100644 (file)
@@ -90,6 +90,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;ex
           file://rpm-platform-file-fix.patch \
           file://rpm-lsb-compatibility.patch \
           file://rpm-tag-generate-endian-conversion-fix.patch \
+          file://rpm-verify-files.patch \
          "
 
 # Uncomment the following line to enable platform score debugging