]> code.ossystems Code Review - openembedded-core.git/commitdiff
expat: use gzip-native for unpack
authorKevin Tian <kevin.tian@intel.com>
Fri, 23 Jul 2010 07:17:06 +0000 (15:17 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 23 Jul 2010 23:01:23 +0000 (00:01 +0100)
expat 2.0.1 archive is generated with DOS format, which causes CRC
error for some version of gzip (<1.4), e.g. on Unbuntu 10.04. This
commit adds do_unpack dependency to gzip-native, and thus to use
local compiled binary to address this issue. Since 1.4 is a known
version solving this issue, also specify a default version for
gzip-native

also move most lines into expat.inc as cleanup

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/conf/distro/include/poky-default.inc
meta/packages/expat/expat.inc
meta/packages/expat/expat_2.0.1.bb

index 0df5cf680acd1847e607ae1c3dcb366aba61554c..d7d70261fbabf9596caff52fa639ffe9c4c589f7 100644 (file)
@@ -42,6 +42,9 @@ PREFERRED_VERSION_glibc-nativesdk ?= "${GLIBCVERSION}"
 PREFERRED_VERSION_glibc-initial ?= "${GLIBCVERSION}"
 PREFERRED_VERSION_glibc-initial-nativesdk ?= "${GLIBCVERSION}"
 PREFERRED_VERSION_elfutils ?= "0.148"
+# don't use version earlier than 1.4 for gzip-native, as it's necessary for
+# some packages using an archive format incompatible with earlier gzip
+PREFERRED_VERSION_gzip-native ?= "1.4"
 
 require conf/distro/include/as-needed.inc
 
index d47e3406298d060194202419e330a653e844244b..8c5010e4816688527418ba6802193cf192068211 100644 (file)
@@ -3,7 +3,17 @@ HOMEPAGE = "http://expat.sourceforge.net/"
 SECTION = "libs"
 LICENSE = "MIT"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+           file://autotools.patch"
 
-inherit autotools
+inherit autotools lib_package
 
+# This package uses an archive format known to have issue with some
+# versions of gzip
+do_unpack[depends] += "gzip-native:do_populate_sysroot"
+
+do_configure_prepend () {
+       rm -f ${S}/conftools/libtool.m4
+}
+
+BBCLASSEXTEND = "native nativesdk"
index da2682e41fa0801363ab8f5d23e52b68744db376..9983fe5838bb0c8a684f6fc84d9c9ca61f402713 100644 (file)
@@ -1,12 +1,3 @@
 require expat.inc
-PR = "r0"
-
-SRC_URI += "file://autotools.patch;"
-
-inherit lib_package
 
-do_configure_prepend () {
-       rm -f ${S}/conftools/libtool.m4
-}
-
-BBCLASSEXTEND = "native nativesdk"
+PR = "r0"