]> code.ossystems Code Review - openembedded-core.git/commitdiff
gconf-dbus: fix watch expressions so that every client doesn't get the server messages
authorRoss Burton <ross@openedhand.com>
Thu, 24 Jan 2008 15:54:33 +0000 (15:54 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 24 Jan 2008 15:54:33 +0000 (15:54 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3586 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gnome/gconf-dbus/notify-fix.patch [new file with mode: 0644]
meta/packages/gnome/gconf-dbus_svn.bb

diff --git a/meta/packages/gnome/gconf-dbus/notify-fix.patch b/meta/packages/gnome/gconf-dbus/notify-fix.patch
new file mode 100644 (file)
index 0000000..278b64a
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gconf/gconf-dbus.c
+===================================================================
+--- gconf/gconf-dbus.c (revision 635)
++++ gconf/gconf-dbus.c (working copy)
+@@ -45,7 +45,7 @@
+ #define DAEMON_NAME_OWNER_CHANGED_RULE \
+     "type='signal',member='NameOwnerChanged',arg0='org.gnome.GConf'"
+ #define NOTIFY_RULE \
+-    "type='method_call',interface='org.gnome.GConf.Database'"
++    "type='method_call',interface='org.gnome.GConf.Database',member='Notify'"
+ #define DAEMON_DISCONNECTED_RULE \
+     "type='signal',member='Disconnected'"
index 0159aaa573373d355cda2a62932ed827a60f4eda..dc9062c0e6c55f8f8e2d8029c55b9ad3a7b051de 100644 (file)
@@ -7,9 +7,10 @@ RPROVIDES_${PN} = "gconf"
 RPROVIDES_${PN}-dev = "gconf-dev"
 
 PV = "2.16.0+svnr${SRCREV}"
-PR = "r4"
+PR = "r5"
 
-SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http"
+SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
+        file://notify-fix.patch;patch=1;pnum=0"
 
 inherit pkgconfig autotools 
 S = "${WORKDIR}/trunk"