]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-config: Add anjuta-remote-run script
authorRichard Purdie <richard@openedhand.com>
Tue, 22 Jan 2008 13:47:08 +0000 (13:47 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 22 Jan 2008 13:47:08 +0000 (13:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3568 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oh/qemu-config.bb
meta/packages/oh/qemu-config/anjuta-remote-run [new file with mode: 0644]

index 381d3bb671b0e1bf68a746accb4e203afd9812ca..299aea2a76734e522a12778e9782b3f49a141d43 100644 (file)
@@ -1,9 +1,10 @@
 DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
 LICENSE = "GPL"
 RDEPENDS = "distcc task-poky-nfs-server fakeroot"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "file://distcc.sh \
+           file://anjuta-remote-run \
            file://exports"
 
 S = "${WORKDIR}"
@@ -15,5 +16,8 @@ do_install() {
     install -d ${D}${sysconfdir}/profile.d
 
     install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
-    install -m 0644 exports ${D}${sysconfdir}
+    install -m 0644 exports ${D}${sysconfdir}/
+    
+    install -d ${D}${bindir}
+    install -m 0755 anjuta-remote-run ${D}${bindir}/
 }    
diff --git a/meta/packages/oh/qemu-config/anjuta-remote-run b/meta/packages/oh/qemu-config/anjuta-remote-run
new file mode 100644 (file)
index 0000000..620e3a7
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+. /etc/profile
+export DISPLAY=:0
+dbus-launch $@
+
+