]> code.ossystems Code Review - openembedded-core.git/commitdiff
bind: Security fix CVE-2015-8461
authorArmin Kuster <akuster@mvista.com>
Sun, 31 Jan 2016 03:29:32 +0000 (19:29 -0800)
committerJoshua Lock <joshua.g.lock@intel.com>
Mon, 29 Feb 2016 15:05:16 +0000 (15:05 +0000)
CVE-2015-8461 bind: race condition when handling socket errors can lead to an assertion failure in resolver.c\

(From OE-Core master rev: 1656eaa722952861ec73362776bd0c4826aec3da)

Hand applied Changelog changes.

Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
meta/recipes-connectivity/bind/bind/CVE-2015-8461.patch [new file with mode: 0644]
meta/recipes-connectivity/bind/bind_9.9.5.bb

diff --git a/meta/recipes-connectivity/bind/bind/CVE-2015-8461.patch b/meta/recipes-connectivity/bind/bind/CVE-2015-8461.patch
new file mode 100644 (file)
index 0000000..32eeeb1
--- /dev/null
@@ -0,0 +1,45 @@
+From adbf81335b67be0cebdcf9f1f4fcb38ef4814f4d Mon Sep 17 00:00:00 2001
+From: Mark Andrews <marka@isc.org>
+Date: Thu, 25 Jun 2015 18:36:27 +1000
+Subject: [PATCH] 4146.   [bug]           Address reference leak that could
+ prevent a clean                         shutdown. [RT #37125]
+
+Upstream-Status: Backport
+
+https://source.isc.org/cgi-bin/gitweb.cgi?p=bind9.git;a=commit;h=adbf81335b67be0cebdcf9f1f4fcb38ef4814f4d
+
+CVE: CVE-2015-8461
+Signed-off-by:  Armin Kuster <akuster@mvista.com>
+---
+ CHANGES            | 3 +++
+ lib/dns/resolver.c | 5 +++++
+ 2 files changed, 8 insertions(+)
+
+Index: bind-9.9.5/lib/dns/resolver.c
+===================================================================
+--- bind-9.9.5.orig/lib/dns/resolver.c
++++ bind-9.9.5/lib/dns/resolver.c
+@@ -1570,6 +1570,11 @@ fctx_query(fetchctx_t *fctx, dns_adbaddr
+       if (query->dispatch != NULL)
+               dns_dispatch_detach(&query->dispatch);
++      LOCK(&res->buckets[fctx->bucketnum].lock);
++      INSIST(fctx->references > 1);
++      fctx->references--;
++      UNLOCK(&res->buckets[fctx->bucketnum].lock);
++
+  cleanup_query:
+       if (query->connects == 0) {
+               query->magic = 0;
+Index: bind-9.9.5/CHANGES
+===================================================================
+--- bind-9.9.5.orig/CHANGES
++++ bind-9.9.5/CHANGES
+@@ -1,4 +1,7 @@
+       --- 9.9.6-P2 released ---
++4146.  [bug]           Address reference leak that could prevent a clean
++                       shutdown. [RT #37125]
++
+ 4053. [security]      Revoking a managed trust anchor and supplying
+                       an untrusted replacement could cause named
index a904d6ebbe88c2843f07d17d712189bbee1a77f5..7ba0d2be3c00db82d6f51e9fd4202baf684bf093 100644 (file)
@@ -27,7 +27,8 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
            file://CVE-2015-5722.patch \
            file://CVE-2015-8000.patch \
            file://CVE-2015-8704.patch \
-          "
+           file://CVE-2015-8461.patch \
+           "
 
 SRC_URI[md5sum] = "e676c65cad5234617ee22f48e328c24e"
 SRC_URI[sha256sum] = "d4b64c1dde442145a316679acff2df4008aa117ae52dfa3a6bc69efecc7840d1"