]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add slang to the dependencies
authorHenning Heinold <henning@itconsulting-heinold.de>
Tue, 24 Jun 2014 21:34:47 +0000 (23:34 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Jul 2014 12:44:53 +0000 (13:44 +0100)
* TUI/GUI support was added in 2.6.35 based on libnewt
* since 3.10 slang replaced libnewt completly
* changing TUI_DEFINES is not necessary, because NO_NEWT is
  still respected with newer kernels
* add comment about the gui history to the recipe

The patch was sponsored by sysmocom

Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 31c2c8eade01b960fd9cc4c84f116811b8229273..0c258e7287f1824ea14b8ebda93e20a488f099c1 100644 (file)
@@ -15,7 +15,10 @@ require perf-features.inc
 
 BUILDPERF_libc-uclibc = "no"
 
-TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt', '',d)}"
+# gui support was added with kernel 3.6.35
+# since 3.10 libnewt was replaced by slang
+# to cover a wide range of kernel we add both dependencies
+TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt slang', '',d)}"
 SCRIPTING_DEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl python', '',d)}"
 
 DEPENDS = "virtual/kernel \