]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools.bbclass: don't create subshell to delete configure scripts
authorAndre McCurdy <armccurdy@gmail.com>
Thu, 28 Jan 2016 20:11:52 +0000 (12:11 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Jan 2016 18:14:57 +0000 (18:14 +0000)
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/autotools.bbclass

index 1400b44999a8d1a83d79d7e619ddd2a188cd0943..4601148fc362f83737c5923975d17f43404d7ea4 100644 (file)
@@ -226,9 +226,9 @@ autotools_do_configure() {
        # for a package whose autotools are old, on an x86_64 machine, which the old
        # config.sub does not support.  Work around this by installing them manually
        # regardless.
-       for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
+       for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
                rm -f `dirname $ac`/configure
-               done )
+       done
        if [ -e ${AUTOTOOLS_SCRIPT_PATH}/configure.in -o -e ${AUTOTOOLS_SCRIPT_PATH}/configure.ac ]; then
                olddir=`pwd`
                cd ${AUTOTOOLS_SCRIPT_PATH}