]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Remove ${B} assignment
authorMichael Gloff <mgloff@emacinc.com>
Sat, 12 Sep 2020 22:39:17 +0000 (17:39 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 13 Sep 2020 12:58:38 +0000 (13:58 +0100)
The VERSION variable is not set unless the
top level Makefile is used as the version is
derived from the Changelog.
If VERSION is not set, none of the binaries built
in the sysvinit recipe will have a valid version
output.
Before:
INIT: version  booting
After:
INIT: version 2.96 booting

Using the top level Makefile does not cause any
additional builds to occur.

Signed-off-by: Michael Gloff <mgloff@emacinc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/sysvinit/sysvinit_2.97.bb

index 80ab9d70e75e99225c89962e1a2ed1377cdef14e..98916f7f19d39412ac7bae5608e1e6aa2373ea9d 100644 (file)
@@ -24,7 +24,6 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/sysvinit/sysvinit-${PV}.tar.xz \
 SRC_URI[sha256sum] = "2d5996857519bfd8634d2e1debabb3238fb38440f65fbfdc46420ee8bdf25110"
 
 S = "${WORKDIR}/sysvinit-${PV}"
-B = "${S}/src"
 
 inherit update-alternatives features_check
 DEPENDS_append = " update-rc.d-native base-passwd virtual/crypt"