]> code.ossystems Code Review - openembedded-core.git/commitdiff
libubootenv: inherit uboot-config
authorMing Liu <liu.ming50@gmail.com>
Tue, 25 Aug 2020 18:08:01 +0000 (20:08 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 26 Aug 2020 08:03:59 +0000 (09:03 +0100)
This mainly aims to involve in the sanity check of UBOOT_CONFIG and
UBOOT_MACHINE, it will throw a error message at recipe parsing time if
neither of them is set, and libubootenv would be skipped.

Signed-off-by: Ming Liu <liu.ming50@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/u-boot/libubootenv_0.3.bb

index 47e64f91145c3012d6ff79f7c69be06d0c9c3c3f..07711484aca08381f96af6fdaeacdbefc37de79c 100644 (file)
@@ -15,7 +15,7 @@ SRCREV = "ad253cfdb07c8492f2ee46a52fbc607ad0b96414"
 
 S = "${WORKDIR}/git"
 
-inherit cmake lib_package
+inherit uboot-config cmake lib_package
 
 EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"