]> code.ossystems Code Review - openembedded-core.git/commitdiff
zlib: refresh patches
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Mar 2018 18:17:59 +0000 (20:17 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Mar 2018 17:16:04 +0000 (09:16 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/zlib/zlib-1.2.11/remove.ldconfig.call.patch

index 403b4825c9bc51cc9c1c20ba76f3b40d5a031eba..7ccbe1f44c67adc4c8beebbe76bb5998aa8eacad 100644 (file)
@@ -7,14 +7,15 @@ So remove ldconfig call from make install-libs
 
 Upstream-Status: Inappropriate [disable feature]
 
-diff -uNr zlib-1.2.6.orig/Makefile.in zlib-1.2.6/Makefile.in
---- zlib-1.2.6.orig/Makefile.in        2012-01-28 23:48:50.000000000 +0100
-+++ zlib-1.2.6/Makefile.in     2012-02-13 15:38:20.577700723 +0100
-@@ -199,7 +199,6 @@
+Index: zlib-1.2.11/Makefile.in
+===================================================================
+--- zlib-1.2.11.orig/Makefile.in
++++ zlib-1.2.11/Makefile.in
+@@ -322,7 +322,6 @@ install-libs: $(LIBS)
          rm -f $(DESTDIR)$(sharedlibdir)/$(SHAREDLIB) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIBM); \
          ln -s $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIB); \
          ln -s $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIBM); \
 -        ($(LDCONFIG) || true)  >/dev/null 2>&1; \
        fi
-       cp zlib.3 $(DESTDIR)$(man3dir)
-       chmod 644 $(DESTDIR)$(man3dir)/zlib.3
+       rm -f $(DESTDIR)$(man3dir)/zlib.3
+       cp $(SRCDIR)zlib.3 $(DESTDIR)$(man3dir)