]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Print a buildtime warning about the status with musl
authorAdrian Bunk <bunk@stusta.de>
Fri, 23 Aug 2019 14:37:49 +0000 (17:37 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 27 Aug 2019 21:52:41 +0000 (22:52 +0100)
It is possible if a user really has to use it, but not recommended.

Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_242.bb

index b368ca8a2c4a2735d4ac22af935ea016926df857..cfa9c079ab0a82c601b2305e99751c2f0288e30e 100644 (file)
@@ -619,6 +619,12 @@ python __anonymous() {
         d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
 }
 
+python do_warn_musl() {
+    if d.getVar('TCLIBC') == "musl":
+        bb.warn("Using systemd with musl is not recommended since it is not supported upstream and some patches are known to be problematic.")
+}
+addtask warn_musl before do_configure
+
 ALTERNATIVE_${PN} = "halt reboot shutdown poweroff runlevel resolv-conf"
 
 ALTERNATIVE_TARGET[resolv-conf] = "${sysconfdir}/resolv-conf.systemd"