]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-tools: do not install shared libraries in ptest package
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 24 Oct 2016 15:37:02 +0000 (18:37 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Nov 2016 10:33:35 +0000 (10:33 +0000)
This was creating a race in runtime library dependency resolution
where sometimes the library was assumed to be provided by the ptest
package.

(From OE-Core rev: c4a10c0b4bc14f4bac06deed8ecb64d0303f4029)

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-kernel/lttng/lttng-tools_git.bb

index bfc657b3ac071f1cd00ebe4f1243e6752c8444b6..b00ce8d2e5c28c1b3156f06c5ce436306477d314 100644 (file)
@@ -113,4 +113,7 @@ do_install_ptest () {
        # checkpatch.pl is unneeded on target and causes file-rdeps QA
        # warnings.
        rm -f ${D}${PTEST_PATH}/extras/checkpatch.pl
+
+        # Remove built libraries as they confuse the packages' runtime dependency resolution
+        rm -rf ${D}${PTEST_PATH}/src/lib/lttng-ctl/.libs/
 }