]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemux86/gstreamer: Move kernel module recommendation to the machine configuration
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2018 10:15:28 +0000 (11:15 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2018 15:47:59 +0000 (16:47 +0100)
If you try to build a system with multiple BSPs, one of which is qemux86
or qemux86-64, the gstreamer package will change.  This will trigger
anything using gstream to also be rebuilt.

For a package based system, the PR values will also be incremented each
time.  The end result will be an ever growing set of PR values as well as
being unable to tell which configured version of the multimedia components
are really being deployed.

These therefore belong in the machine configuration.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/machine/qemux86-64.conf
meta/conf/machine/qemux86.conf
meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb

index fd1f4142e9b3a90c349884a3a9c10418b76b0610..9966d1a04c847211266e1a318a3120a06288a98f 100644 (file)
@@ -31,6 +31,8 @@ MACHINE_FEATURES += "x86 pci"
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d"
 
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
+
 KERNEL_MODULE_AUTOLOAD += "uvesafb"
 KERNEL_MODULE_PROBECONF += "uvesafb"
 module_conf_uvesafb = "options uvesafb mode_option=${UVESA_MODE}"
index efcebb278257bab31b19a1ed590d584565510b4e..e78fb6e87b66bb1b7e4158fd69dcf96d06579296 100644 (file)
@@ -30,6 +30,8 @@ MACHINE_FEATURES += "x86 pci"
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d"
 
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
+
 KERNEL_MODULE_AUTOLOAD += "uvesafb"
 KERNEL_MODULE_PROBECONF += "uvesafb"
 module_conf_uvesafb = "options uvesafb mode_option=${UVESA_MODE}"
index 7f291f66303c4ddf048308eaa54d11fcd9c9c199..3a6e53de04579b6b3223fc292682010da98bc294 100644 (file)
@@ -55,8 +55,6 @@ FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
 FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
 FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
 
-RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
-RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
 RDEPENDS_${PN}-ptest += "make"
 
 delete_pkg_m4_file() {