]> code.ossystems Code Review - openembedded-core.git/commitdiff
pigz: install pigz, unpigz, pigzcat in native and nativesdk builds again
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 12 Jun 2019 19:48:16 +0000 (19:48 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Jun 2019 22:15:45 +0000 (23:15 +0100)
* since this commit:
  commit ad1db93d134db1ec4f6d6598c9741dc13e82e1f3
  Author: Anuj Mittal <anuj.mittal@intel.com>
  Date:   Tue May 28 06:32:10 2019 +0800
  Subject: Revert "pigz: pigz is not gzip"

  pigz-native and nativesdk-pigz no longer installs pigz, unpigz, pigzcat,
  so scripts explicitly depending on pigz-native and calling pigz started to fail.

* reverse the logic
  - all the builds install pigz, unpigz, pigzcat
  - only the native one installs it as gzip as well

* it could be optimized a bit more to create gzip as just a symlink
  in native case as well, but they are in different directories
  (pigz in base_bindir and gzip in bindir) and it's only 130kB..

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/pigz/pigz_2.4.bb

index 974c0351474f5fa2ca129f9bbc88bc76a9b26566..6d62ce6cc551131a907edeaa1550d188fe4f43d1 100644 (file)
@@ -23,7 +23,7 @@ EXTRA_OEMAKE = "-e MAKEFLAGS="
 
 inherit update-alternatives
 
-do_install_class-target() {
+do_install() {
        # Install files into /bin (FHS), which is typical place for gzip
        install -d ${D}${base_bindir}
        install ${B}/pigz ${D}${base_bindir}/pigz
@@ -31,7 +31,7 @@ do_install_class-target() {
        ln -nsf pigz ${D}${base_bindir}/pigzcat
 }
 
-do_install() {
+do_install_append_class-native() {
        install -d ${D}${bindir}
        install ${B}/pigz ${D}${bindir}/gzip
        ln -nsf gzip ${D}${bindir}/gunzip