]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add galago/libgalago from OE
authorRichard Purdie <richard@openedhand.com>
Thu, 13 Oct 2005 11:44:16 +0000 (11:44 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 13 Oct 2005 11:44:16 +0000 (11:44 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@136 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/galago/files/no-check.patch [new file with mode: 0644]
openembedded/packages/galago/galago-daemon_0.3.4.bb [new file with mode: 0644]
openembedded/packages/galago/libgalago_0.3.3.bb [new file with mode: 0644]

diff --git a/openembedded/packages/galago/files/no-check.patch b/openembedded/packages/galago/files/no-check.patch
new file mode 100644 (file)
index 0000000..89b0eaf
--- /dev/null
@@ -0,0 +1,15 @@
+--- /tmp/configure.ac  2005-09-08 21:38:49.316449440 +0200
++++ libgalago-0.3.3/configure.ac       2005-09-08 21:39:32.697854464 +0200
+@@ -198,11 +198,8 @@
+ dnl #
+ dnl # Check for Check
+ dnl #
+-AM_PATH_CHECK(, [have_check="yes"],
+-[
+-      AC_MSG_WARN([Check not found; cannot run some unit tests])
+       have_check="no"
+-])
++
+ AM_CONDITIONAL(HAVE_CHECK, test "$have_check" = "yes")
diff --git a/openembedded/packages/galago/galago-daemon_0.3.4.bb b/openembedded/packages/galago/galago-daemon_0.3.4.bb
new file mode 100644 (file)
index 0000000..610b9f7
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION =   "Galago is a desktop presence framework, designed to transmit presence information between programs."
+HOMEPAGE =      "http://www.galago-project.org/"
+MAINTAINER =    "Koen Kooi <koen@handhelds.org>"
+LICENSE =       "GPL"
+DEPENDS =       "gettext libgalago dbus glib-2.0"
+
+
+SRC_URI =       "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+                 file://no-check.patch;patch=1"
+EXTRA_OECONF = "--disable-binreloc"
+
+inherit autotools pkgconfig
+
diff --git a/openembedded/packages/galago/libgalago_0.3.3.bb b/openembedded/packages/galago/libgalago_0.3.3.bb
new file mode 100644 (file)
index 0000000..85f4097
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION =  "Galago is a desktop presence framework, designed to transmit presence information between programs."
+HOMEPAGE =     "http://www.galago-project.org/"
+MAINTAINER =   "Koen Kooi <koen@handhelds.org>"
+LICENSE =      "LGPL"
+DEPENDS =      "gettext dbus glib-2.0"
+PR =           "r1"
+
+
+SRC_URI =      "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+                file://no-check.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+       autotools_stage_includes
+       install -d ${STAGING_LIBDIR}
+       install -m 755 libgalago/.libs/libgalago.so.1.0.0 ${STAGING_LIBDIR}/libgalago.so
+}