]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.4: fix PAT for 32bit x86
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sat, 2 Apr 2016 00:09:24 +0000 (20:09 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 Apr 2016 14:51:09 +0000 (15:51 +0100)
Integrating the following mainline destined commits to fix PAT issues with
32bit x86 and qemu:

  bc22b90fb583 x86/pat: Document the PAT initialization sequence
  c534b1ec1991 x86/xen, pat: Remove PAT table init code from Xen
  cd47692e804f x86/mtrr: Fix PAT init handling when MTRR is disabled
  039434bdc165 x86/mtrr: Fix Xorg crashes in Qemu sessions
  c08196e8064c x86/mm/pat: Replace cpu_has_pat with boot_cpu_has()
  6928fce8c766 x86/mm/pat: Add pat_disable() interface
  3163c8d5468d x86/mm/pat: Add support of non-default PAT MSR setting

With this change applied, we once again have working graphics and no special
work arounds.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
meta/recipes-kernel/linux/linux-yocto_4.4.bb

index e6a03928b9b09f5a08063bd24b511c73215c52e5..a3b743b1d984b9b311ae1083f7eecf82ce0b7364 100644 (file)
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-SRCREV_machine ?= "56434a6d9850fd3642bab5cab63d22c6f56d2eae"
+SRCREV_machine ?= "1970b2704b881effa78c3e5f79c0fd3bff1fd028"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
index 2b7e1cb4d723b53699662874d7a819d0073694e8..67e261c6a6c6d0b03200b5781d54b1a139e51fd3 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.4.3"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 5280777f80c09ac46877ee1581544a732d4e7265..0494564a5bdb353f29a20fe30054c5fac503202e 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "03f244ec7482dbc1c924af73a317dd3d12f00132"
-SRCREV_machine_qemuarm64 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
-SRCREV_machine_qemumips ?= "4cd732b14cf4bdb51b7b565783bbc2ce5ab9a943"
-SRCREV_machine_qemuppc ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
-SRCREV_machine_qemux86 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
-SRCREV_machine_qemux86-64 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
-SRCREV_machine_qemumips64 ?= "699473bc2476afa85e47833f0f47aaf44a799257"
-SRCREV_machine ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine_qemuarm ?= "8abee78b727ce6a4df262d1befcbecfa26742ae0"
+SRCREV_machine_qemuarm64 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine_qemumips ?= "475e28c3240610c26ee0b7866dc0ce701d0c27e1"
+SRCREV_machine_qemuppc ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine_qemux86 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine_qemux86-64 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine_qemumips64 ?= "8d34fd84b9c53507b3d10a4a44294c479237319c"
+SRCREV_machine ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \