]> code.ossystems Code Review - openembedded-core.git/commitdiff
jpeg: add link libjpeg.so.62 for LSB library test
authorKang Kai <kai.kang@windriver.com>
Fri, 15 Apr 2011 10:26:00 +0000 (18:26 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Apr 2011 04:48:28 +0000 (05:48 +0100)
LSB test just test whether libjpeg.so.62 exists, and no more use of it.
So just make link to pass library check.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/jpeg/jpeg_8b.bb

index 8e2c24dd21a22c9ce22ac4413432c93db5e25998..78fabf1efdc7a9ae647cafaa2178928d6d6f76ca 100644 (file)
@@ -14,7 +14,7 @@ PRIORITY = "required"
 DEPENDS = "libtool-cross"
 DEPENDS_virtclass-native = "libtool-native"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
           file://debian-libjpeg7_7-1.diff;patch=1"
@@ -45,3 +45,14 @@ DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs fo
 FILES_jpeg-tools =     "${bindir}/*"
 
 BBCLASSEXTEND = "native"
+
+pkg_postinst_${PN}_poky-lsb () {
+    if [ "$D" = "" ]; then
+        if [ ! -e ${libdir}/libjpeg.so.62 ]; then
+            JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
+            ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
+        fi
+    else
+        exit 1
+    fi
+}