]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: do not install 'devices' initscript - we do not support devfsd
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:19:47 +0000 (14:19 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:19:47 +0000 (14:19 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4640 311d38ba-8fff-0310-9ca6-ca027cbcb966

15 files changed:
meta/packages/initscripts/initscripts-1.0/akita/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/c7x0/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/collie/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/h3600/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/h3900/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/jornada56x/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/jornada6xx/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/jornada7xx/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/poodle/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/simpad/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/spitz/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/tosa/devices [deleted file]
meta/packages/initscripts/initscripts-1.0/uml/devices [deleted file]
meta/packages/initscripts/initscripts_1.0.bb

diff --git a/meta/packages/initscripts/initscripts-1.0/akita/devices b/meta/packages/initscripts/initscripts-1.0/akita/devices
deleted file mode 100755 (executable)
index 083090e..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/input
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /dev/sharp_ts /dev/ts
-        ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/c7x0/devices b/meta/packages/initscripts/initscripts-1.0/c7x0/devices
deleted file mode 100755 (executable)
index 083090e..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/input
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /dev/sharp_ts /dev/ts
-        ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/collie/devices b/meta/packages/initscripts/initscripts-1.0/collie/devices
deleted file mode 100755 (executable)
index 9d16244..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /dev/sharp_ts /dev/ts
-       ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/devices b/meta/packages/initscripts/initscripts-1.0/devices
deleted file mode 100755 (executable)
index 67a2ec8..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udev -o -e /dev/.udevdb; then
-       exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/input
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/vc
-       mkdir -p dev/snd
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/h3600/devices b/meta/packages/initscripts/initscripts-1.0/h3600/devices
deleted file mode 100755 (executable)
index 0e59229..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-    test -n "$VERBOSE" && echo -n "Setting up device links for devfs: "
-    (
-    ln -s /dev/vc/0 /dev/tty0
-    ln -s /dev/vc/1 /dev/tty1
-    ln -s /dev/vc/2 /dev/tty2
-    ln -s /dev/vc/3 /dev/tty3
-    ln -s /dev/vc/4 /dev/tty4
-    ln -s /dev/vc/5 /dev/tty5
-    ln -s /dev/fb/0 /dev/fb0
-    # ln -s /dev/tts/0 /dev/ttySA0
-    # ln -s /dev/tts/1 /dev/ttySA1
-    # ln -s /dev/tts/2 /dev/ttySA2
-
-    ln -s /dev/sound/dsp /dev/dsp
-    ln -s /dev/sound/mixer /dev/mixer
-
-    ln -s /dev/v4l/video0 /dev/video0
-    ln -s /dev/v4l/video0 /dev/video
-    ln -s /dev/misc/rtc /dev/rtc
-    ln -s /dev/misc/apm_bios /dev/apm_bios
-
-    ## need this so that ppp will autoload the ppp modules
-    mknod /dev/ppp c 108 0
-    )  > /dev/null 2>&1
-
-
-    test -n "$VERBOSE" && echo "done"
diff --git a/meta/packages/initscripts/initscripts-1.0/h3900/devices b/meta/packages/initscripts/initscripts-1.0/h3900/devices
deleted file mode 100755 (executable)
index 0e59229..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-    test -n "$VERBOSE" && echo -n "Setting up device links for devfs: "
-    (
-    ln -s /dev/vc/0 /dev/tty0
-    ln -s /dev/vc/1 /dev/tty1
-    ln -s /dev/vc/2 /dev/tty2
-    ln -s /dev/vc/3 /dev/tty3
-    ln -s /dev/vc/4 /dev/tty4
-    ln -s /dev/vc/5 /dev/tty5
-    ln -s /dev/fb/0 /dev/fb0
-    # ln -s /dev/tts/0 /dev/ttySA0
-    # ln -s /dev/tts/1 /dev/ttySA1
-    # ln -s /dev/tts/2 /dev/ttySA2
-
-    ln -s /dev/sound/dsp /dev/dsp
-    ln -s /dev/sound/mixer /dev/mixer
-
-    ln -s /dev/v4l/video0 /dev/video0
-    ln -s /dev/v4l/video0 /dev/video
-    ln -s /dev/misc/rtc /dev/rtc
-    ln -s /dev/misc/apm_bios /dev/apm_bios
-
-    ## need this so that ppp will autoload the ppp modules
-    mknod /dev/ppp c 108 0
-    )  > /dev/null 2>&1
-
-
-    test -n "$VERBOSE" && echo "done"
diff --git a/meta/packages/initscripts/initscripts-1.0/jornada56x/devices b/meta/packages/initscripts/initscripts-1.0/jornada56x/devices
deleted file mode 100755 (executable)
index 0e59229..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-    test -n "$VERBOSE" && echo -n "Setting up device links for devfs: "
-    (
-    ln -s /dev/vc/0 /dev/tty0
-    ln -s /dev/vc/1 /dev/tty1
-    ln -s /dev/vc/2 /dev/tty2
-    ln -s /dev/vc/3 /dev/tty3
-    ln -s /dev/vc/4 /dev/tty4
-    ln -s /dev/vc/5 /dev/tty5
-    ln -s /dev/fb/0 /dev/fb0
-    # ln -s /dev/tts/0 /dev/ttySA0
-    # ln -s /dev/tts/1 /dev/ttySA1
-    # ln -s /dev/tts/2 /dev/ttySA2
-
-    ln -s /dev/sound/dsp /dev/dsp
-    ln -s /dev/sound/mixer /dev/mixer
-
-    ln -s /dev/v4l/video0 /dev/video0
-    ln -s /dev/v4l/video0 /dev/video
-    ln -s /dev/misc/rtc /dev/rtc
-    ln -s /dev/misc/apm_bios /dev/apm_bios
-
-    ## need this so that ppp will autoload the ppp modules
-    mknod /dev/ppp c 108 0
-    )  > /dev/null 2>&1
-
-
-    test -n "$VERBOSE" && echo "done"
diff --git a/meta/packages/initscripts/initscripts-1.0/jornada6xx/devices b/meta/packages/initscripts/initscripts-1.0/jornada6xx/devices
deleted file mode 100644 (file)
index 5ca2a1c..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-       exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-        
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/input
-        mknod /dev/input/ts0 c 13 128
-        mknod /dev/ttySC0 c 8 204
-       mknod /dev/ttySC1 c 9 204
-        mknod /dev/ttySC2 c 10 204
-       
-       mknod /dev/irda0  c 10 204
-        
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/jornada7xx/devices b/meta/packages/initscripts/initscripts-1.0/jornada7xx/devices
deleted file mode 100755 (executable)
index 422336a..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-       exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-        
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/input
-        mknod /dev/input/ts0 c 13 65
-       mknod /dev/ttySC1 c 9 204
-       mknod /dev/irda0  c 10 204
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/poodle/devices b/meta/packages/initscripts/initscripts-1.0/poodle/devices
deleted file mode 100755 (executable)
index 9d16244..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /dev/sharp_ts /dev/ts
-       ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/simpad/devices b/meta/packages/initscripts/initscripts-1.0/simpad/devices
deleted file mode 100644 (file)
index 0e59229..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-    test -n "$VERBOSE" && echo -n "Setting up device links for devfs: "
-    (
-    ln -s /dev/vc/0 /dev/tty0
-    ln -s /dev/vc/1 /dev/tty1
-    ln -s /dev/vc/2 /dev/tty2
-    ln -s /dev/vc/3 /dev/tty3
-    ln -s /dev/vc/4 /dev/tty4
-    ln -s /dev/vc/5 /dev/tty5
-    ln -s /dev/fb/0 /dev/fb0
-    # ln -s /dev/tts/0 /dev/ttySA0
-    # ln -s /dev/tts/1 /dev/ttySA1
-    # ln -s /dev/tts/2 /dev/ttySA2
-
-    ln -s /dev/sound/dsp /dev/dsp
-    ln -s /dev/sound/mixer /dev/mixer
-
-    ln -s /dev/v4l/video0 /dev/video0
-    ln -s /dev/v4l/video0 /dev/video
-    ln -s /dev/misc/rtc /dev/rtc
-    ln -s /dev/misc/apm_bios /dev/apm_bios
-
-    ## need this so that ppp will autoload the ppp modules
-    mknod /dev/ppp c 108 0
-    )  > /dev/null 2>&1
-
-
-    test -n "$VERBOSE" && echo "done"
diff --git a/meta/packages/initscripts/initscripts-1.0/spitz/devices b/meta/packages/initscripts/initscripts-1.0/spitz/devices
deleted file mode 100755 (executable)
index 083090e..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       mkdir -p dev/input
-       mkdir -p dev/vc
-       for i in 0 1 2 3 4 5 6 7 8 9; do
-               ln -s /dev/tty$i /dev/vc/$i
-       done
-       ln -sf /dev/sharp_ts /dev/ts
-        ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/tosa/devices b/meta/packages/initscripts/initscripts-1.0/tosa/devices
deleted file mode 100755 (executable)
index 61cfd9d..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-        mkdir -p dev/input
-        mkdir -p dev/vc
-        for i in 0 1 2 3 4 5 6 7 8 9; do
-                ln -s /dev/tty$i /dev/vc/$i
-        done
-       ln -sf /dev/sharp_ts /dev/ts
-        ln -sf /dev/sharp_fl /dev/fl
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-#Always turn on usb
-if [ ! -d /dev/usb ]; then mkdir /dev/usb; fi
-mknod /dev/usb/host_ohci c 10 222
-
-exit 0
diff --git a/meta/packages/initscripts/initscripts-1.0/uml/devices b/meta/packages/initscripts/initscripts-1.0/uml/devices
deleted file mode 100755 (executable)
index d6459c1..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script.  Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
-    exit 0
-fi
-
-if test -e /dev/.devfsd
-then
-       if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
-       ln -s /dev/touchscreen/0 /dev/ts
-       ln -s /dev/touchscreen/0raw /dev/tsraw
-       ln -s /dev/vc/0 /dev/tty0
-       ln -s /dev/vc/1 /dev/tty1
-       ln -s /dev/vc/2 /dev/tty2
-       ln -s /dev/vc/3 /dev/tty3
-       ln -s /dev/vc/4 /dev/tty4
-       ln -s /dev/vc/5 /dev/tty5
-       ln -s /dev/fb/0 /dev/fb0
-#      ln -s /dev/tts/0 /dev/ttySA0
-#      ln -s /dev/tts/1 /dev/ttySA1
-#      ln -s /dev/tts/2 /dev/ttySA2
-
-       ln -s /dev/sound/dsp /dev/dsp
-       ln -s /dev/sound/mixer /dev/mixer
-
-       ln -s /dev/v4l/video0 /dev/video0
-       ln -s /dev/v4l/video0 /dev/video
-       ln -s /dev/misc/rtc /dev/rtc
-
-       ## need this so that ppp will autoload the ppp modules
-       mknod /dev/ppp c 108 0
-       if test "$VERBOSE" != "no"; then echo "done"; fi
-else
-       if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-       mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-       if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
-       cd /
-       mkdir -p dev/msys
-       mkdir -p dev/pts
-       ln -sf /proc/self/fd /dev/fd
-       ln -sf /proc/kcore /dev/core
-       /sbin/makedevs -r / -D /etc/device_table
-       if test $? -ne 0; then
-               if test "$VERBOSE" != "no"; then echo "failed"; fi
-       else
-               if test "$VERBOSE" != "no"; then echo "done"; fi
-       fi
-fi
-
-exit 0
index 242e85086e47cc2758ba87516d330739572be11d..ac01a428191385eb7dafdb32c17c1b938413e7e3 100644 (file)
@@ -4,13 +4,12 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r106"
+PR = "r107"
 
 SRC_URI = "file://functions \
            file://halt \
            file://ramdisk \
            file://umountfs \
-           file://devices \
            file://devpts.sh \
            file://devpts \
            file://hostname.sh \
@@ -81,7 +80,6 @@ do_install () {
 # Install device dependent scripts
 #
        install -m 0755 ${WORKDIR}/banner       ${D}${sysconfdir}/init.d/banner
-       install -m 0755 ${WORKDIR}/devices      ${D}${sysconfdir}/init.d/devices
        install -m 0755 ${WORKDIR}/umountfs     ${D}${sysconfdir}/init.d/umountfs
 #
 # Create runlevel links
@@ -114,7 +112,6 @@ do_install () {
        ln -sf          ../init.d/bootmisc.sh   ${D}${sysconfdir}/rcS.d/S55bootmisc.sh
 #      ln -sf          ../init.d/urandom       ${D}${sysconfdir}/rcS.d/S55urandom
        ln -sf          ../init.d/finish        ${D}${sysconfdir}/rcS.d/S99finish
-       ln -sf          ../init.d/devices       ${D}${sysconfdir}/rcS.d/S05devices
        # udev will run at S04 if installed
        ln -sf          ../init.d/sysfs.sh      ${D}${sysconfdir}/rcS.d/S03sysfs
        ln -sf          ../init.d/populate-volatile.sh  ${D}${sysconfdir}/rcS.d/S37populate-volatile.sh