]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: realpath is required before expanding _dbpath in chroot
authorMing Liu <ming.liu@windriver.com>
Tue, 21 Oct 2014 11:10:54 +0000 (19:10 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Oct 2014 16:31:58 +0000 (17:31 +0100)
A regression is introduced by commit 66573093:
[ rpm: Fix rpm relocation macro usage ]

_usr turned out to be a relative path to support dyanmic config after
that, but it's being used somewhere as a indicator to locate substrings,
so we must get the real path of it in advance.

Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/rpm/rpm/rpm-realpath.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
meta/recipes-devtools/rpm/rpm_5.4.14.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-realpath.patch b/meta/recipes-devtools/rpm/rpm/rpm-realpath.patch
new file mode 100644 (file)
index 0000000..d2d9b09
--- /dev/null
@@ -0,0 +1,24 @@
+chroot: realpath is required before expanding _dbpath
+
+_usr turned out to be a relative path to support dyanmic config, but it's
+being used somewhere as a indicator to locate substrings, so we must get
+the real path of it in advance.
+
+Upstream-Status: Inapproriate (OpenEmbedded specific)
+
+Signed-off-by: Ming Liu <ming.liu@windriver.com>
+
+diff -urpN a/rpmio/rpmrpc.c b/rpmio/rpmrpc.c
+--- a/rpmio/rpmrpc.c
++++ b/rpmio/rpmrpc.c
+@@ -257,7 +257,9 @@ int Open(const char * path, int flags, m
+     /* XXX if the open(2) fails, try to strip a possible chroot(2) prefix. */
+     if (fdno < 0 && errno == ENOENT) {
+       const char *dbpath = rpmExpand("%{?_dbpath}/", NULL);
+-      const char * fn = strstr(path + 1, dbpath);
++      char resolved_dbpath[PATH_MAX];
++      realpath(dbpath, resolved_dbpath);
++      const char * fn = strstr(path + 1, resolved_dbpath);
+       if (fn)
+           fdno = open(fn, flags, mode);
+       dbpath = _free(dbpath);
index d2dec5f3d1de37d8ee791a2094fde8577ae1acf9..a85e28fa1f405604e4180fdf804ed3e42dc3520f 100644 (file)
@@ -109,6 +109,7 @@ SRC_URI = "cvs://anonymous@rpm5.org/cvs;tag=rpm-5_4;module=rpm \
           file://rpm-db5-or-db6.patch \
           file://rpm-rpmpgp-fix.patch \
           file://rpm-disable-Wno-override-init.patch \
+          file://rpm-realpath.patch \
          "
 
 # Uncomment the following line to enable platform score debugging
index fb8a50706fc6d5a04e3fb80e01f6a1bd47bc3987..6cd932d5e90242589774acdef2aaec0ebf1d1b5d 100644 (file)
@@ -93,6 +93,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;e
           file://rpm-db5-or-db6.patch \
           file://rpm-disable-Wno-override-init.patch \
           file://rpmqv_cc_b_gone.patch \
+          file://rpm-realpath.patch \
          "
 
 # Uncomment the following line to enable platform score debugging