]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: we use system ffi so no need to autoreconf in-tree libffi
authorRoss Burton <ross.burton@intel.com>
Tue, 11 Sep 2018 15:25:54 +0000 (16:25 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Sep 2018 23:27:55 +0000 (00:27 +0100)
For target Python we use the libffi that we build, so we don't need to
autoreconf the in-tree libffi.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.5.6.bb

index d341b2773ea74ba5141e7d46ad311c2b011f70a0..2d8fa1adb73bfa8330981eb9a490fcdb35ca746e 100644 (file)
@@ -84,7 +84,6 @@ PACKAGECONFIG[pgo] = "--enable-optimizations"
 
 do_configure_append() {
        rm -f ${S}/Makefile.orig
-       autoreconf -Wcross --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
 }
 
 run_make() {