]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: import gcc3 check from OE
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 19 Oct 2007 14:30:34 +0000 (14:30 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 19 Oct 2007 14:30:34 +0000 (14:30 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2936 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-gcc3-check.inc [new file with mode: 0644]
meta/packages/qemu/qemu-native_20070613.bb
meta/packages/qemu/qemu-native_cvs.bb

diff --git a/meta/packages/qemu/qemu-gcc3-check.inc b/meta/packages/qemu/qemu-gcc3-check.inc
new file mode 100644 (file)
index 0000000..96b79fd
--- /dev/null
@@ -0,0 +1,20 @@
+python __anonymous() {
+    from bb import which, data
+
+    path = data.getVar('PATH', d)
+    oldOeConf = data.getVar('EXTRA_OECONF', d)
+    if not oldOeConf: oldOeConf = ""
+    if len(which(path, 'gcc-3.4')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc-3.4", d)
+    elif len(which(path, 'gcc34')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc34", d)
+    elif len(which(path, 'gcc33')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc33", d)
+    elif len(which(path, 'gcc-3.3')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc-3.3", d)
+    elif len(which(path, 'gcc-3.3.6')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc-3.3.6", d)
+    elif len(which(path, 'gcc-3.4.6')) != 0:
+        data.setVar('EXTRA_OECONF', oldOeConf + " --cc=gcc-3.4.6", d)
+}
+
index 03a433b23282aed67293575a1e7eb73f676dce84..a6a5bda58d98c02934fc11b6e6c9d7961d4b5eea 100644 (file)
@@ -3,16 +3,4 @@ inherit native
 DEPENDS = "zlib-native"
 prefix = "${STAGING_DIR}/${BUILD_SYS}"
 
-python __anonymous() {
-    from bb import which, data
-       
-    path = data.getVar('PATH', d)
-    oeconf = data.getVar('EXTRA_OECONF', d) or ''
-    if len(which(path, 'gcc-3.4')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.4", d)
-    elif len(which(path, 'gcc34')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc34", d)
-    elif len(which(path, 'gcc-3.3')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.3", d)
-    #data.setVarFlag('PKG_CONFIG_PATH', 'unexport', '1', d)
-}
+require qemu-gcc3-check.inc
index 01cc9c181d13f1d469797fcc794435b5802f67f0..fae6ca2f1bf3f765ffbc44a22206498903b3a079 100644 (file)
@@ -3,16 +3,4 @@ inherit native
 DEPENDS = "zlib-native"
 prefix = "${STAGING_DIR}/${BUILD_SYS}"
 
-python __anonymous() {
-    from bb import which, data
-       
-    path = data.getVar('PATH', d)
-    oeconf = data.getVar('EXTRA_OECONF', d) or ''
-    if len(which(path, 'gcc-3.4')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.4", d)
-    elif len(which(path, 'gcc34')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc34", d)
-    elif len(which(path, 'gcc-3.3')) != 0:
-        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.3", d)
-    #data.setVarFlag('PKG_CONFIG_PATH', 'unexport', '1', d)
-}
+require qemu-gcc3-check.inc