]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnss-mdns: dont use hard coded /lib path
authorKumar Gala <galak@kernel.crashing.org>
Wed, 3 Aug 2011 15:28:48 +0000 (10:28 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Aug 2011 16:48:28 +0000 (17:48 +0100)
As libdir might not be /lib (could be /lib64) use ${base_libdir} instead of
hard coded "/lib" in configure options set in EXTRA_OECONF.

Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb

index f5df005d30fdebca969db68868a8d15529babc62..5f614f86a2cd68196f5185ccb2dd77f2f61d931c 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
 DEPENDS = "avahi"
 RDEPENDS_${PN} = "avahi-daemon"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz"
 
@@ -21,7 +21,7 @@ inherit autotools
 LEAD_SONAME = "libnss_mdns.so"
 DEBIANNAME_${PN} = "libnss-mdns"
 
-EXTRA_OECONF = "--libdir=/lib --disable-lynx --enable-avahi"
+EXTRA_OECONF = "--libdir=${base_libdir} --disable-lynx --enable-avahi"
 
 # TODO: pattern based configuration update
 pkg_postinst_${PN} () {