]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-doc-utils: Package up python site packages, bump PR
authorTom Rini <tom_rini@mentor.com>
Mon, 18 Jul 2011 15:46:35 +0000 (08:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2011 14:24:56 +0000 (15:24 +0100)
Add python-dir to the inherits list so we can grab the python site packages
files as well.  This fixes a 'installed but not packaged' QA problem with
the python site package files.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
meta/recipes-gnome/gnome/gnome-doc-utils.inc
meta/recipes-gnome/gnome/gnome-doc-utils_0.20.6.bb

index 7f1ab83f5988f0a600f7ce8af2b1d55f54b2dff7..bd7c615eb99bd1084c84ea162ce580db61286a53 100644 (file)
@@ -2,7 +2,7 @@ LICENSE = "GPL & LGPL"
 DEPENDS = "libxml2 libxslt libxslt-native gnome-doc-utils-native"
 DEPENDS_virtclass-native = "libxml2-native libxslt-native intltool-native"
 
-inherit gnome gettext
+inherit gnome gettext python-dir
 
 EXTRA_OECONF = "--disable-scrollkeeper"
 
@@ -13,7 +13,7 @@ do_install_append() {
        chown -R root:root ${D}
 }
 
-FILES_${PN} += "${datadir}/xml*"
+FILES_${PN} += "${datadir}/xml* ${PYTHON_SITEPACKAGES_DIR}/*"
 
 RDEPENDS_${PN} = "bash"
 
index 0019f451b1222a4fd03a9c0c7b7b377434cc2924..4554122ddc5b098b8b5b923f3533c64c4d03e2c0 100644 (file)
@@ -1,7 +1,7 @@
 require gnome-doc-utils.inc
 LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
                    file://COPYING.LGPL;md5=a6f89e2100d9b6cdffcea4f398e37343"
-PR = "r2"
+PR = "r3"
 
 SRC_URI += "file://xsltproc_nonet.patch"