]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: Add patch to correct failing build
authorCristian Iorga <cristian.iorga@intel.com>
Tue, 5 Jun 2012 18:51:17 +0000 (21:51 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 5 Jun 2012 22:01:30 +0000 (23:01 +0100)
ltp makefile does not interpret correctly the result of git describe
command and assumes that it is working with a git repo, while in fact
working with a source code archive.
Added a patch to corect makefile system.

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20120401.bb

diff --git a/meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch b/meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch
new file mode 100644 (file)
index 0000000..a8064cf
--- /dev/null
@@ -0,0 +1,13 @@
+Index: ltp-20120401/Makefile
+===================================================================
+--- ltp-20120401.orig/Makefile
++++ ltp-20120401/Makefile
+@@ -173,7 +173,7 @@ SRCDIR_INSTALL_TARGETS     := $(SRCDIR_INSTA
+ #
+ .PHONY: Version
+ Version:
+-      if git describe &> /dev/null; then \
++      if git describe > /dev/null 2>&1; then \
+               git describe > "$@"; \
+       else \
+               cp VERSION "$@"; \
index 912d6d906b67bc2d2d2b2bfaca6e9b17bc969674..563bd58bf8147b3d003556ea4d68c03fcd84b5fe 100644 (file)
@@ -21,10 +21,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
 
 DEPENDS = "attr"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.bz2 \
-          "
+           file://fix_building_fom_archive.patch"
 
 SRC_URI[md5sum] = "e1d0acf1a6b6da0cb30dc1b0dcf5f26d"
 SRC_URI[sha256sum] = "f0f5845f9666f61332fdf0b7e396fc647f9372db0902a829af2cf9402b807bd1"