]> code.ossystems Code Review - openembedded-core.git/commitdiff
lz4: add r112
authorKoen Kooi <koen.kooi@linaro.org>
Tue, 14 Jan 2014 11:00:45 +0000 (12:00 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jan 2014 11:50:47 +0000 (11:50 +0000)
lz4-native is needed for kernels using lz4 compression, which was merged in 3.11.

Lz4 has a similar compression rate to lzo but decompresses a lot (>4x) faster.

Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/lz4/lz4_svn.bb [new file with mode: 0644]

diff --git a/meta/recipes-support/lz4/lz4_svn.bb b/meta/recipes-support/lz4/lz4_svn.bb
new file mode 100644 (file)
index 0000000..41464e2
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2008d2325e11691e17fcaa3a6046f850"
+
+# Upstream names releases after SVN revs
+SRCREV = "112"
+PV = "r${SRCREV}"
+
+SRC_URI = "svn://lz4.googlecode.com/svn/;module=trunk;protocol=http"
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC=${TARGET_PREFIX}gcc DESTDIR=${D}"
+
+BBCLASSEXTEND += "native nativesdk"