]> code.ossystems Code Review - openembedded-core.git/commitdiff
ptest-runner: pass libdir to DEFAULT_DIRECTORY when compiling
authorLi Zhou <li.zhou@windriver.com>
Tue, 22 Jan 2019 09:00:27 +0000 (17:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2019 17:45:18 +0000 (17:45 +0000)
Ptest data are installed to PTEST_PATH ?= "${libdir}/${BPN}/ptest".
When libdir isn't "/usr/lib", it will cause "No ptests found" error
when running "ptest-runner" command. Here pass libdir to
DEFAULT_DIRECTORY when compiling to avoid that error.

Need update ptest-runner source code to get the new commit:
<ptest-runner: make DEFAULT_DIRECTORY be able to be defined when compiling>

Signed-off-by: Li Zhou <li.zhou@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/ptest-runner/ptest-runner_2.3.bb

index 26add9b0a0512731590ea9c22a36dab1d6ed4c63..0a58f74ea25cde49f97b69f4b6a9e936702cbdb6 100644 (file)
@@ -7,7 +7,7 @@ HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
 
-SRCREV = "80712583732b4a809532f644fb09e7d2e812d7ba"
+SRCREV = "e1062f776eea60c50435c6b8ddf9714a31141aee"
 PV = "2.3+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
 
 FILES_${PN} = "${bindir}/ptest-runner"
 
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
 
 do_compile () {
        oe_runmake