]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-dri, mesa-xlib: fix compilation with x32 toolchain
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 2 Dec 2011 20:20:03 +0000 (12:20 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Dec 2011 22:42:48 +0000 (22:42 +0000)
Add support for building with x32 toolchain.

Simplified the use of SRC_URI & S vars across multiple files.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-7.11.inc
meta/recipes-graphics/mesa/mesa-common.inc
meta/recipes-graphics/mesa/mesa-dri_7.11.bb
meta/recipes-graphics/mesa/mesa-git.inc
meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch [new file with mode: 0644]

index 2f14ed4f2b8eeba8d1ed97f2d3acf7ce1110b3a2..7c4a6904d93564ba5418d98a9dd3b5d5ac94a4b8 100644 (file)
@@ -1,9 +1,14 @@
 DEPENDS += "mesa-dri-glsl-native"
 
-SRC_URI += "file://uclibc.patch \
-            file://crossfix.patch \
-            file://crossfix-mklib.patch \
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \ 
+           file://uclibc.patch \
+           file://crossfix.patch \
+           file://crossfix-mklib.patch \
+           file://mesa_fix_for_x32.patch \
            "
+S = "${WORKDIR}/Mesa-${PV}"
+
 SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
 SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
 
index df035e6e270e9d305368e05ed84cb8f3401a1434..59e8e6480da930cd6557cb758bc9ffd5fd0f4918 100644 (file)
@@ -15,8 +15,6 @@ LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1
 INC_PR = "r13"
 PE = "2"
 
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
-S = "${WORKDIR}/Mesa-${PV}"
 
 PROTO_DEPS = "xf86driproto glproto"
 LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
index 5d25127fcf7523633ebc9907292d8b55e17e5a17..219e55517c2f6eb66bde5f36a94ef559db484f47 100644 (file)
@@ -1,4 +1,4 @@
 include mesa-common.inc
 include mesa-${PV}.inc
 include mesa-dri.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
index 594d9b8adbca27bd6210069b2ddf385fa33f9fd1..1b4c0a69b415df4540f7f05c5fc67011d04ad5af 100644 (file)
@@ -6,9 +6,9 @@ PV = "7.11+gitr${SRCPV}"
 LIC_FILES_CHKSUM = "file://docs/license.html;md5=03ccdc4c379c4289aecfb8892c546f67"
 FILESEXTRAPATHS_prepend := "${THISDIR}/mesa-git:"
 
-SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git"
-SRC_URI += "file://uclibc.patch \
-            file://crossfix.patch \
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
+           file://uclibc.patch \
+           file://crossfix.patch \
            "
 S = "${WORKDIR}/git"
 
index 7912287fe0765bf312ecea005c0d99cc5d96096c..7547b22cc792423fb88266444f14d3ad8bdea0d5 100644 (file)
@@ -1,5 +1,5 @@
 include mesa-common.inc
 include mesa-${PV}.inc
 include mesa-xlib.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 
diff --git a/meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch b/meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch
new file mode 100644 (file)
index 0000000..22a2339
--- /dev/null
@@ -0,0 +1,24 @@
+UpstreamStatus: Pending
+
+get correct compiler options for x32 gcc.
+
+Received this patch from H.J. Lu <hjl.tools@gmail.com>
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/01
+
+--- Mesa-7.11/bin/mklib.x32    2011-11-30 14:29:14.976465283 -0800
++++ Mesa-7.11/bin/mklib        2011-11-30 14:32:48.591525193 -0800
+@@ -335,7 +335,12 @@ case $ARCH in
+           set ${OBJECTS}
+           ABI32=`file $1 | grep 32-bit`
+           if [ "${ABI32}" -a `uname -m` = "x86_64" ] ; then
+-              OPTS="-m32 ${OPTS}"
++              ABIX32=`file $1 | grep x86-64`
++              if [ "${ABI32}" ]; then
++                  OPTS="-mx32 ${OPTS}"
++              else
++                  OPTS="-m32 ${OPTS}"
++              fi
+           fi
+             if [ "${ALTOPTS}" ] ; then