]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake: upgrade 3.22.2 -> 3.22.3
authorwangmy <wangmy@fujitsu.com>
Mon, 7 Mar 2022 13:01:22 +0000 (21:01 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Mar 2022 22:43:48 +0000 (22:43 +0000)
refresh 0001-CMakeDetermineSystem-use-oe-environment-vars-to-load.patch

Changelog:
==========
* The :command:'while' command again ignores errors in condition evaluation
  as CMake 3.21 and below did.  This bug was fixed in 3.22.0, but exposed
  errors in existing projects.  The fix has been reverted to restore
  compatibility.  The fix may be restored in a future version of CMake
  via a policy.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake-native_3.22.3.bb [moved from meta/recipes-devtools/cmake/cmake-native_3.22.2.bb with 100% similarity]
meta/recipes-devtools/cmake/cmake.inc
meta/recipes-devtools/cmake/cmake/0001-CMakeDetermineSystem-use-oe-environment-vars-to-load.patch
meta/recipes-devtools/cmake/cmake_3.22.3.bb [moved from meta/recipes-devtools/cmake/cmake_3.22.2.bb with 100% similarity]

index a8bd4311c4ad7955c863b63c2aa5a9b835927936..d5003211389d66c0f8ce7afc97cab8aa69895bea 100644 (file)
@@ -21,7 +21,7 @@ SRC_URI = "https://cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz \
            file://0004-Fail-silently-if-system-Qt-installation-is-broken.patch \
 "
 
-SRC_URI[sha256sum] = "3c1c478b9650b107d452c5bd545c72e2fad4e37c09b89a1984b9a2f46df6aced"
+SRC_URI[sha256sum] = "9f8469166f94553b6978a16ee29227ec49a2eb5ceb608275dec40d8ae0d1b5a0"
 
 UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
 
index 9609f5f7c24582402d1c7ee5b96bf9b416c47bf1..9a2287f517be7738a26a6c50b297ba9dd8d16afa 100644 (file)
@@ -1,4 +1,4 @@
-From e75f76b00cc9c1cfc231c5e731e975552f5dd13e Mon Sep 17 00:00:00 2001
+From 89f6c846f02ad6d30b9ebb7eaaaa4fb6f9cec054 Mon Sep 17 00:00:00 2001
 From: Cody P Schafer <dev@codyps.com>
 Date: Thu, 27 Apr 2017 11:35:05 -0400
 Subject: [PATCH] CMakeDetermineSystem: use oe environment vars to load default
@@ -25,10 +25,10 @@ Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
  1 file changed, 7 insertions(+)
 
 diff --git a/Modules/CMakeDetermineSystem.cmake b/Modules/CMakeDetermineSystem.cmake
-index bae270de..5bb6bc0d 100644
+index 8c7af067..ade2b189 100644
 --- a/Modules/CMakeDetermineSystem.cmake
 +++ b/Modules/CMakeDetermineSystem.cmake
-@@ -111,6 +111,13 @@ else()
+@@ -112,6 +112,13 @@ else()
    endif()
  endif()