]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: remove redundant ac_cv_sizeof_off_t assignments
authorRoss Burton <ross.burton@intel.com>
Mon, 11 Apr 2016 19:49:23 +0000 (20:49 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Apr 2016 20:56:28 +0000 (21:56 +0100)
ac_cv_sizeof_off_t was previously in the site cache files, which was breaking
large file support and required a workaround in each recipe that actually wanted
to use large files.

Now that the entry has been removed from the site cache, we can remove the
workarounds.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub-efi_2.00.bb
meta/recipes-bsp/grub/grub_2.00.bb
meta/recipes-bsp/grub/grub_git.bb
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python_2.7.11.bb
meta/recipes-extended/pax/pax_3.4.bb
meta/recipes-multimedia/libsndfile/libsndfile1_1.0.26.bb
meta/recipes-support/curl/curl_7.47.1.bb

index dbc034ce541ff10f485f6528bd86106619bcb4d8..5a0dc954a3bf97bc2e770549de2e1224a04c7afb 100644 (file)
@@ -33,7 +33,7 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
                 --enable-efiemu=no --program-prefix='' \
                 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
 
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
 
 # ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
 # and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
index addc1b2833153bf14b8229db08b7a1e89eca9db7..778074a387324af6041397ec4487a224b29427f2 100644 (file)
@@ -6,7 +6,7 @@ PR = "r1"
 EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
                --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
 
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
 
 do_install_append () {
     install -d ${D}${sysconfdir}/grub.d
index 3ebab7f2f832fb0c10b22314450c1c4743de6ad8..6919c9a351a1158a1785bb4a9e8823211de8ce83 100644 (file)
@@ -31,7 +31,7 @@ GRUBPLATFORM ??= "pc"
 EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
                 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
 
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
 
 do_configure_prepend() {
     ( cd ${S}
index 52250d27bbe4b0efe64cada25afb04843684d94b..f4818c6a87770824d3239d8039b9727a500dee33 100644 (file)
@@ -20,8 +20,6 @@ PYTHON_MAJMIN = "2.7"
 
 inherit autotools
 
-PYTHONLSBOPTS_linuxstdbase = "ac_cv_sizeof_off_t=8"
-
 EXTRA_OECONF = "\
   --with-threads \
   --with-pymalloc \
index 0c00d6e4e40f23f11ea4ad1c2c39710b52b80cba..606f153623b843896e6e5b40f709fd274f5dce6d 100644 (file)
@@ -35,8 +35,7 @@ inherit autotools multilib_header python-dir pythonnative
 
 CONFIGUREOPTS += " --with-system-ffi "
 
-# The following is a hack until we drop ac_cv_sizeof_off_t from site files
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)} ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
+EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
 
 do_configure_append() {
        rm -f ${S}/Makefile.orig
index cee52e3e578a8739e2b5372bd2fda01276090740..9d1abfbb5431a8142ea8118c601c3408786db85d 100644 (file)
@@ -25,8 +25,4 @@ SRC_URI_append_libc-musl = " file://0001-Fix-build-with-musl.patch \
 SRC_URI[md5sum] = "fbd9023b590b45ac3ade95870702a0d6"
 SRC_URI[sha256sum] = "ac3c06048e02828077cf7757d3d142241429238893b91d529af29a2e8cc5623b"
 
-# see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html
-# We should ideally drop ac_cv_sizeof_off_t from site files but until then
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}"
-
 inherit autotools
index a5ac84e301ce40625cf3754bb063a0d38fd50fac..80435d4b5bb708ec5859516e797fbcba476e05b6 100644 (file)
@@ -22,6 +22,5 @@ inherit autotools lib_package pkgconfig
 do_configure_prepend_arm() {
        export ac_cv_sys_largefile_source=1
        export ac_cv_sys_file_offset_bits=64
-       ac_cv_sizeof_off_t=8
 }
 
index 7e2664c2d9a8d83fd6342bb1fde351454034f894..c2173d8a06843073c45cf2c4ccf92c3e07f82a22 100644 (file)
@@ -49,10 +49,6 @@ EXTRA_OECONF = " \
     --without-nghttp2 \
 "
 
-# see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html
-# We should ideally drop ac_cv_sizeof_off_t from site files but until then
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}"
-
 do_install_append() {
        oe_multilib_header curl/curlbuild.h
 }