]> code.ossystems Code Review - openembedded-core.git/commitdiff
routerstationpro: create machine conf and compatibility
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sun, 10 Oct 2010 18:11:07 +0000 (14:11 -0400)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 21:56:28 +0000 (22:56 +0100)
BUGID: 422

Add the machine configuration and kernel infrastructure for building
the routerstation pro BSP.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/conf/machine/routerstationpro.conf [new file with mode: 0644]
meta/recipes-kernel/linux/linux-wrs_git.bb

index c325260c6d6c873fd0a080f386f7249fddbc2cc6..5f36c7b5e72a9e40395518b4867ae30a21fff030 100644 (file)
@@ -89,6 +89,7 @@ SRCREV_machine_pn-linux-wrs_qemux86 ?= "0431115c9d720fee5bb105f6a7411efb4f851d26
 SRCREV_machine_pn-linux-wrs_qemux86-64 ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
 SRCREV_machine_pn-linux-wrs_emenlow ?= "aae69fdf104b0a9d7b3710f808aac6ab303490f7"
 SRCREV_machine_pn-linux-wrs_atom-pc ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
+SRCREV_machine_pn-linux-wrs_routerstationpro ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
 SRCREV_meta_pn-linux-wrs ?= "bfef596973ae436db9132065eaab2228c98f938b"
 SRCREV_pn-linux-libc-headers-wrs ??= "09a39c638dd65dc27c549c119abe1af2631b2ae0"
 SRCREV_pn-matchbox-config-gtk ??= "2081"
diff --git a/meta/conf/machine/routerstationpro.conf b/meta/conf/machine/routerstationpro.conf
new file mode 100644 (file)
index 0000000..ecacc9b
--- /dev/null
@@ -0,0 +1,23 @@
+#@TYPE: Machine
+#@NAME: mti_malta32_be MIPS
+#@DESCRIPTION: mti_malta32_be
+
+TARGET_ARCH = "mips"
+
+require conf/machine/include/tune-mips32.inc
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 \
+                    serial usbgadget"
+
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-wrs"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+IMAGE_ROOTFS_SIZE_ext3 = "2000000"
+IMAGE_FSTYPES ?= "jffs2 tar.bz2"
+
index f6b0aead55c86a6744049c0a60955dabb5a2f263..f99be25c7528adc8a78b81b83f487308be4a7b54 100644 (file)
@@ -26,12 +26,13 @@ WRMACHINE_qemuppc  = "qemu_ppc32"
 WRMACHINE_qemumips = "mti_malta32_be"
 WRMACHINE_qemuarm  = "arm_versatile_926ejs"
 WRMACHINE_atom-pc  = "common_pc"
+WRMACHINE_routerstationpro = "routerstationpro"
 
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
 
 LINUX_VERSION = "v2.6.34"
 LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r7"
+PR = "r8"
 
 S = "${WORKDIR}/linux"
 B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
@@ -166,6 +167,9 @@ do_wrlinux_configcheck() {
 }
 
 do_wrlinux_link_vmlinux() {
+       if [ ! -d "${B}/arch/${ARCH}/boot" ]; then
+               mkdir ${B}/arch/${ARCH}/boot
+       fi
        cd ${B}/arch/${ARCH}/boot
        ln -sf ../../../vmlinux
 }