]> code.ossystems Code Review - openembedded-core.git/commitdiff
util-linux: Fix build when NLS is disabled
authorKhem Raj <raj.khem@gmail.com>
Thu, 1 Mar 2012 07:55:00 +0000 (23:55 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Mar 2012 15:49:25 +0000 (15:49 +0000)
AC_CHECK_DECLS generated defines should be
checked with #if not #ifdef

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch [new file with mode: 0644]
meta/recipes-core/util-linux/util-linux_2.21.bb

diff --git a/meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch b/meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch
new file mode 100644 (file)
index 0000000..545c3a9
--- /dev/null
@@ -0,0 +1,24 @@
+configure uses AC_CHECK_DECLS to check for _NL_TIME_WEEK_1STDAY
+which means we will get HAVE_DECL__NL_TIME_WEEK_1STDAY
+defined to 1 if symbol is declared, otherwise to 0 in config.h
+
+Therefore we cannot rely on conditionals which check for it
+being defined or not since it always will be defined so correct
+thing is to use #if instead of #ifdef
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: util-linux-2.21/misc-utils/cal.c
+===================================================================
+--- util-linux-2.21.orig/misc-utils/cal.c      2012-02-29 23:41:54.413347665 -0800
++++ util-linux-2.21/misc-utils/cal.c   2012-02-29 23:42:44.573350057 -0800
+@@ -297,7 +297,7 @@
+  * the locale database, which can be overridden with the
+  * -s (Sunday) or -m (Monday) options.
+  */
+-#ifdef HAVE_DECL__NL_TIME_WEEK_1STDAY
++#if HAVE_DECL__NL_TIME_WEEK_1STDAY
+       /*
+        * You need to use 2 locale variables to get the first day of the week.
+        * This is needed to support first_weekday=2 and first_workday=1 for
index e21f484b7925b6e4439b08a4cd787b0f7269d70c..744dbaf58bc63154d4818108f81984c82fa4e2ee 100644 (file)
@@ -1,5 +1,5 @@
 MAJOR_VERSION = "2.21"
-PR = "r1"
+PR = "r2"
 require util-linux.inc
 
 # note that `lscpu' is under GPLv3+
@@ -7,7 +7,8 @@ LICENSE_util-linux-lscpu = "GPLv3+"
 
 SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
             file://util-linux-ng-2.16-mount_lock_path.patch \
-            file://uclibc-__progname-conflict.patch \      
+            file://uclibc-__progname-conflict.patch \
+            file://fix_NL_TIME_FIRST_WEEKDAY.patch \
 "
 
 SRC_URI[md5sum] = "3c7a26963f3921c1e775a80330321870"