]> code.ossystems Code Review - openembedded-core.git/commitdiff
console-tools: use u-a also for fgconsole otherwise it collides with busybox
authorMartin Jansa <martin.jansa@gmail.com>
Thu, 26 May 2011 21:04:13 +0000 (23:04 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 May 2011 23:35:11 +0000 (00:35 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/console-tools/console-tools_0.3.2.bb

index c7bee61591f02a59491e495358a713fda759ba2b..c740119306a9ad209e129631c632fdf6411c5d38 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
 SUMMARY = "Allows you to set-up and manipulate the Linux console."
 DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
            file://codepage.patch;patch=1 \
@@ -37,17 +37,20 @@ do_install () {
        mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
        mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
        mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+       mv ${D}${bindir}/fgconsole ${D}${bindir}/fgconsole.${PN}
 }
 
 pkg_postinst_${PN} () {
        update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
        update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
        update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+       update-alternatives --install ${bindir}/fgconsole fgconsole fgconsole.${PN} 100
 }
 
 pkg_prerm_${PN} () {
        update-alternatives --remove chvt chvt.${PN}
        update-alternatives --remove deallocvt deallocvt.${PN}
        update-alternatives --remove openvt openvt.${PN}
+       update-alternatives --remove fgconsole fgconsole.${PN}
 }