]> code.ossystems Code Review - openembedded-core.git/commitdiff
Drop the 'ui failed to start' message, as the ui_init does more in knotty
authorChris Larson <chris_larson@mentor.com>
Fri, 6 Aug 2010 23:08:32 +0000 (16:08 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 4 Jan 2011 14:36:54 +0000 (14:36 +0000)
(Bitbake rev: 39087138ffd5d427f07ecaa580a40885c5ffaff3)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 797b5a8d602227944a966bc5afe99bed0bf11b35..9556fb04414f5b119829ea90f5e7a5673dbd3924 100755 (executable)
@@ -202,11 +202,7 @@ Default BBFILES are the .bb files in the current directory.""")
         print("FATAL: Invalid user interface '%s' specified. " % ui)
         print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
     else:
-        try:
-            return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
-        except Exception as e:
-            print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
-            raise
+        return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
     finally:
         serverConnection.terminate()