]> code.ossystems Code Review - openembedded-core.git/commitdiff
kern_tools: wrs kernel manipulation tools
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 18 Jun 2010 05:04:26 +0000 (01:04 -0400)
committerBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 19 Jul 2010 15:59:38 +0000 (11:59 -0400)
These tools are largely unused at the moment, but represent
a baseline set of functionality for working with a Wind River
Linux kernel.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/packages/kern-tools/kern-tools-native_git.bb [new file with mode: 0644]

index 9e39e534b9e89b45fd88ab0db8129ae8c21758bb..a65e5876d74d8bed65d93cb00859f0311cd2bcf0 100644 (file)
@@ -47,6 +47,7 @@ SRCREV_pn-gypsy ??= "147"
 SRCREV_pn-inputproto ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-native ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-nativesdk ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
+SRCREV_pn-kern-tools-native ??= "20d390ef5001d99a72c19a525751aeb76ca85a19"
 SRCREV_pn-libdrm ??= "3f3c5be6f908272199ccf53f108b1124bfe0a00e"
 SRCREV_pn-libfakekey ??= "2031"
 SRCREV_pn-libgdbus ??= "aeab6e3c0185b271ca343b439470491b99cc587f"
diff --git a/meta/packages/kern-tools/kern-tools-native_git.bb b/meta/packages/kern-tools/kern-tools-native_git.bb
new file mode 100644 (file)
index 0000000..417bcb6
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "Scripts and utilities for managing Wind River kernels."
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d843f43d2e22b0d91a6fee"
+
+DEPENDS = "git-native"
+
+PR = r4
+PV = "0.1+git${SRCPV}"
+
+# needed until the native do_stage goes away
+NATIVE_INSTALL_WORKS=1
+
+inherit native
+
+SRC_URI = "git://git.pokylinux.org/wr-kernel-tools.git;protocol=git"
+S = "${WORKDIR}"
+
+kern_tools_LIST = kgit kgit-init kgit-meta \
+                  kgit-checkpoint kgit-clean \
+                  generate_cfg kconf_check configme
+
+do_compile() { 
+       :
+}
+
+do_install() {
+       install -d ${D}${bindir}
+       for s in ${kern_tools_LIST}; do
+           install -m 0755 ${S}/git/tools/$s ${D}${bindir}
+       done
+}