]> code.ossystems Code Review - openembedded-core.git/commitdiff
llvm: doesn't actually need pythonnative
authorRoss Burton <ross.burton@intel.com>
Wed, 27 Mar 2019 23:07:11 +0000 (23:07 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Mar 2019 08:26:27 +0000 (08:26 +0000)
LLVM doesn't actually need pythonnative, the host Python2 is sufficient but
cmake's executable searching currently isn't reliable in cross-compilations.

Convince cmake by setting PYTHON_EXECUTABLE to point at python2 in the HOSTTOOLS
directory.  Note that currently LLVM *needs* python2 currently:

https://github.com/llvm-mirror/llvm/blob/master/CMakeLists.txt#L670

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/llvm/llvm_git.bb

index d2ea927651de3e70d7faf15be37e4ecb7e21b39b..31abadcace5dacb938de115d859f1c89b9dcff30 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "libffi libxml2 zlib ninja-native llvm-native"
 
 RDEPENDS_${PN}_append_class-target = " ncurses-terminfo"
 
-inherit perlnative pythonnative cmake pkgconfig
+inherit perlnative cmake pkgconfig
 
 PROVIDES += "llvm${PV}"
 
@@ -74,6 +74,7 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
                   -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
                   -DLLVM_OPTIMIZED_TABLEGEN=ON \
                   -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
+                  -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
                   -G Ninja"
 
 EXTRA_OECMAKE_append_class-target = "\