]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Fix makefile race causing configuration differences
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 19 Feb 2020 14:38:23 +0000 (14:38 +0000)
committerArmin Kuster <akuster808@gmail.com>
Sun, 23 Feb 2020 17:39:42 +0000 (09:39 -0800)
Add a missing makefile dependency which can cause differences in
configuration (submitted upstream).

[YOCTO #13800]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit fe97845a45434902c5a994e253a127a462d7d3b4)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/perl/files/racefix.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl_5.30.1.bb

diff --git a/meta/recipes-devtools/perl/files/racefix.patch b/meta/recipes-devtools/perl/files/racefix.patch
new file mode 100644 (file)
index 0000000..bac42d2
--- /dev/null
@@ -0,0 +1,24 @@
+In our builds Config_heavy.pl sometimes has lines:
+cwarnflags=XXX
+ccstdflags=XXX
+and sometimes does not.
+The reason is that this information is pulled from cflags by configpm and yet
+there is no dependency in the Makefile. Add one to fix this.
+
+Upstream-Status: Submitted [https://github.com/arsv/perl-cross/pull/89]
+RP 2020/2/19
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Index: perl-5.30.1/Makefile
+===================================================================
+--- perl-5.30.1.orig/Makefile
++++ perl-5.30.1/Makefile
+@@ -204,7 +204,7 @@ configpod: $(CONFIGPOD)
+ git_version.h lib/Config_git.pl: make_patchnum.pl | miniperl$X
+       ./miniperl_top make_patchnum.pl
+-lib/Config.pm lib/Config_heavy.pl lib/Config.pod: config.sh \
++lib/Config.pm lib/Config_heavy.pl lib/Config.pod: config.sh cflags \
+               lib/Config_git.pl Porting/Glossary | miniperl$X
+       ./miniperl_top configpm
index e3915a504489afea68815e03fef931456e0685e7..32746c70956fd061fc7ce7346d9de522b628e82f 100644 (file)
@@ -22,6 +22,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
            file://0002-Constant-Fix-up-shebang.patch \
            file://0001-tests-adjust-to-correctly-exclude-unbuilt-extensions.patch \
            file://determinism.patch  \
+           file://racefix.patch \
            "
 SRC_URI_append_class-native = " \
            file://perl-configpm-switch.patch \