]> code.ossystems Code Review - openembedded-core.git/commitdiff
insserv: Fix a cross compile issue on i386 machines
authorRichard Purdie <richard@openedhand.com>
Mon, 25 Aug 2008 15:05:03 +0000 (15:05 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 25 Aug 2008 15:05:03 +0000 (15:05 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5090 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/insserv/files/crosscompile_fix.patch [new file with mode: 0644]
meta/packages/insserv/insserv_1.11.0.bb

diff --git a/meta/packages/insserv/files/crosscompile_fix.patch b/meta/packages/insserv/files/crosscompile_fix.patch
new file mode 100644 (file)
index 0000000..14d8db4
--- /dev/null
@@ -0,0 +1,22 @@
+Index: insserv-1.11.0/Makefile
+===================================================================
+--- insserv-1.11.0.orig/Makefile       2008-08-25 16:00:00.000000000 +0100
++++ insserv-1.11.0/Makefile    2008-08-25 16:00:25.000000000 +0100
+@@ -18,16 +18,7 @@
+ #
+ # Architecture
+ #
+-ifdef RPM_OPT_FLAGS
+-        COPTS = -g $(RPM_OPT_FLAGS)
+-else
+-         ARCH = $(shell uname -i)
+-ifeq ($(ARCH),i386)
+-        COPTS = -O2 -mcpu=i586 -mtune=i686
+-else
+-        COPTS = -O2
+-endif
+-endif
++COPTS = -O2
+ COPTS += -g
+        MY_CFLAGS = $(CFLAGS) -Wall $(COPTS) $(DEBUG) $(LOOPS) -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
index e567401f378b6482a1b7d8daf2165c05587912f1..b5938b25ba03ea71893fb760974c0395e895ef64 100644 (file)
@@ -1,10 +1,12 @@
 LICENSE = "GPL"
 SECTION = "base"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.suse.com/pub/projects/init/${PN}-${PV}.tar.gz \
         file://40_segfault_virtprov.dpatch;patch=1 \
         file://42_loopnochangemsg.dpatch;patch=1 \
         file://make.patch;patch=1 \
+        file://crosscompile_fix.patch;patch=1 \
         file://insserv.conf"
 
 do_install () {