]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: make tools needed for API documentation respect the manpages PACKAGECONFIG
authorRoss Burton <ross.burton@intel.com>
Tue, 9 Oct 2018 14:05:34 +0000 (15:05 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 11:42:40 +0000 (12:42 +0100)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 514c87835d0bb84a3b9b762cec76baaf7d2cdaac..586422f769ea233cde93964f921da24bfe6e5b2a 100644 (file)
@@ -22,17 +22,15 @@ PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
 PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
 PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
 PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
-
 # libaudit support would need scripting to be enabled
 PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
+PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
 
 DEPENDS = " \
     virtual/${MLPREFIX}libc \
     ${MLPREFIX}elfutils \
     ${MLPREFIX}binutils \
     bison-native flex-native xz \
-    xmlto-native \
-    asciidoc-native \
 "
 
 do_configure[depends] += "virtual/kernel:do_shared_workdir"