]> code.ossystems Code Review - openembedded-core.git/commitdiff
directfb: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 14:27:18 +0000 (14:27 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 17:04:56 +0000 (17:04 +0000)
Add patch to allow out of tree builds to work.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/directfb/directfb/fixsepbuild.patch [new file with mode: 0644]
meta/recipes-graphics/directfb/directfb_1.6.1.bb

diff --git a/meta/recipes-graphics/directfb/directfb/fixsepbuild.patch b/meta/recipes-graphics/directfb/directfb/fixsepbuild.patch
new file mode 100644 (file)
index 0000000..94a9ba5
--- /dev/null
@@ -0,0 +1,19 @@
+Fix out of tree builds
+
+Upstream-Status: Pending
+
+RP 2013/03/21
+
+Index: DirectFB-1.6.1/configure.in
+===================================================================
+--- DirectFB-1.6.1.orig/configure.in   2013-03-19 01:38:28.174004720 +0000
++++ DirectFB-1.6.1/configure.in        2013-03-21 12:18:10.253113675 +0000
+@@ -111,7 +111,7 @@
+ AC_PATH_TOOL(FLUXCOMP, fluxcomp)
+ AC_SUBST(FLUXCOMP)
+ if test -z "$FLUXCOMP"; then
+-  if ! test -e src/core/CoreDFB.cpp; then
++  if ! test -e $srcdir/src/core/CoreDFB.cpp; then
+     AC_MSG_ERROR([
+ *** DirectFB compilation requires fluxcomp ***
index 6c48a86f81df52d1e5f3fc69163dbc56d6da7422..1230d129443d3272382c5135d467cbd43f6c0b2d 100644 (file)
@@ -6,7 +6,8 @@ PR = "${INC_PR}.2"
 DEPENDS += "sysfsutils"
 
 SRC_URI += "file://fix-compilation-with-zlib.patch \
-            file://rename-no-instrument-function-macro.patch"
+            file://rename-no-instrument-function-macro.patch \
+            file://fixsepbuild.patch"
 
 EXTRA_OECONF = "\
   --enable-freetype=yes \