]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs_1.42.bb: Fix build fallout for uclibc
authorKhem Raj <raj.khem@gmail.com>
Wed, 18 Jan 2012 03:01:05 +0000 (19:01 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2012 11:29:04 +0000 (11:29 +0000)
e2fsprogs 1.42 onwards uses fallocate() which uclibc
does not implement(yet). In most of places its use
is controlled and it only used when configure detects
fallocate being present but in this one case it missed
to check for fallocate being available so here we
add the check

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch [new file with mode: 0644]
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb

diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch
new file mode 100644 (file)
index 0000000..4d952a5
--- /dev/null
@@ -0,0 +1,22 @@
+We assume that fallocate is supported somehow
+but we need to check if we have fallocate()
+this problem shows up on uclibc systems since
+uclibc does not have fallocate() implemented
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: e2fsprogs-1.42/lib/ext2fs/unix_io.c
+===================================================================
+--- e2fsprogs-1.42.orig/lib/ext2fs/unix_io.c   2012-01-17 17:24:34.290780625 -0800
++++ e2fsprogs-1.42/lib/ext2fs/unix_io.c        2012-01-17 17:25:37.338783680 -0800
+@@ -895,7 +895,7 @@
+               goto unimplemented;
+ #endif
+       } else {
+-#ifdef FALLOC_FL_PUNCH_HOLE
++#if defined FALLOC_FL_PUNCH_HOLE && defined HAVE_FALLOCATE
+               /*
+                * If we are not on block device, try to use punch hole
+                * to reclaim free space.
index 9ff85a2d5120e1bd1c1479b761c856836558a054..f6759aa7d48f8066719f8c08b1b97618a72b9ae4 100644 (file)
@@ -1,8 +1,9 @@
 require e2fsprogs.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI += "file://quotefix.patch \
+            file://fallocate.patch \
             file://acinclude.m4"
 
 SRC_URI[md5sum] = "a3c4ffd7352310ab5e9412965d575610"