]> code.ossystems Code Review - openembedded-core.git/commitdiff
remake: Fix out of tree builds
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 2 Apr 2013 11:55:27 +0000 (11:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 2 Apr 2013 16:55:05 +0000 (17:55 +0100)
remake fails with errors during configure due to the out of tree build changes.
This ensures the configure commands run correctly on files in ${S}.

[YOCTO #4139]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/remake/remake_git.bb

index a7cf54e32073a40f1f8d4d2cc90ed85b086e10c7..afbc5d0710746d404f6055331431c451eab3df12 100644 (file)
@@ -16,10 +16,10 @@ PROVIDES += "make"
 
 do_configure_prepend() {
     # remove the default LINGUAS since we are not going to generate languages
-    rm po/LINGUAS
-    touch po/LINGUAS
+    rm ${S}/po/LINGUAS
+    touch ${S}/po/LINGUAS
     # create config.rpath which required by configure.ac
-    autopoint || touch config.rpath
+    ( cd ${S}; autopoint || touch config.rpath )
 }
 
 BBCLASSEXTEND = "native"