]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi: fix the /var/run conflict with other package
authorYu Ke <ke.yu@intel.com>
Tue, 27 Jul 2010 08:05:29 +0000 (16:05 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 30 Jul 2010 13:50:30 +0000 (14:50 +0100)
avahi will create an empty /var/run dir, which will conflict with base-files package.
This patch fix this by using populate-volatiles.sh approach recommended by OE handbook.

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/packages/avahi/avahi.inc
meta/packages/avahi/avahi_0.6.27.bb

index 4e2949319639fc96ee9aa7ac48f45635fa614f5c..2a5bf4a1820dbf134abb87166f6c8fbaaebdfe7d 100644 (file)
@@ -64,6 +64,15 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
 INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
 INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
 
+do_install() {
+       autotools_do_install
+
+       # don't install /var/run when populating rootfs. Do it through volatile
+       # /var/run of current version is empty, so just remove it.
+       # if /var/run become non-empty in the future, need to install it via volatile
+       rm -rf ${D}/var/run
+}
+
 # At the time the postinst runs, dbus might not be setup so only restart if running
 
 pkg_postinst_avahi-daemon () {
index 736c61582c9765c6e083ae1ed290307d27595922..a4c22a8b0e7c291b478c2b4232cf1dba4252580c 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
                     file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
 
 RDEPENDS_avahi-daemon = "sysvinit-pidof"
-PR = "r0"
+PR = "r1"
 
 EXTRA_OECONF += "--disable-gtk3"