]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-tools-testapps: clear GOTOOLS for riscv32
authorKai Kang <kai.kang@windriver.com>
Thu, 2 Dec 2021 02:35:58 +0000 (10:35 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 3 Dec 2021 23:36:21 +0000 (23:36 +0000)
go-helloworld is not compatible with riscv32 and causes error:

| ERROR: Nothing RPROVIDES 'go-helloworld' (but
    meta/recipes-core/packagegroups/packagegroup-core-tools-testapps.bb
    RDEPENDS on or otherwise requires it)
| go-helloworld was skipped: Unsupported CPU architecture: riscv32

Clear GOTOOLS for riscv32 in recipe packagegroup-core-tools-testapps.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/packagegroups/packagegroup-core-tools-testapps.bb

index e8f081148591cc3139dc309af1a5656a96162b78..1fee1c925db4b962e0e134a614c1ed87e3e551de 100644 (file)
@@ -23,6 +23,7 @@ KEXECTOOLS:riscv32 ?= ""
 # gccgo may do better
 GOTOOLS ?= "go-helloworld"
 GOTOOLS:powerpc ?= ""
+GOTOOLS:riscv32 ?= ""
 
 GSTEXAMPLES ?= "gst-examples"
 GSTEXAMPLES:riscv64 = ""